I am searching for a Linux software to control the 3000 mW laser engraver depicted below. It's a common model you'd find on AliExpress, Banggood, etc. under different brand names.

I have already tried nejePrint, LaserWeb, and EzGraver, but they don't work. Any ideas?

enter image description here

  • 3
    $\begingroup$ Did you have any reason to believe it would work under Linux? If you buy something unsupported then you are the support. These things don’t just automatically have Linux drivers, someone has to write them. If you get any useful messages when you try connecting it you might be able to ask on a Linux forum and see if you can get it to work. Also you’re going to need to be a lot more specific than “it doesn’t work”. $\endgroup$
    – T. M.
    Jun 12, 2019 at 10:57
  • 2
    $\begingroup$ You say you've tried all the different software listed, but are you sure it's the software? How do you know the printer itself isn't defective? $\endgroup$ Jun 12, 2019 at 11:09
  • $\begingroup$ The literature clearly says it does not support *nix systems. $\endgroup$ Jun 12, 2019 at 15:36
  • $\begingroup$ This looks like a small Linux development project more than a laser marking or 3D printing project. Although it could be fun to help, you might get better information for the first steps (such as connecting the device to Linux) at the UNIX StackExchange site: unix.stackexchange.com . They handle Linux as well as Unix questions. $\endgroup$
    – cmm
    Jun 17, 2019 at 13:28

6 Answers 6


I just found https://github.com/aquamorta/kkengraver:

This software is intended to be used with a KKMoon laser engraver (3000mW). It comes with ABSOLUTELY NO WARRANTY. It may or may not work with an other kind of laser engraver.

Some good internet guy/girl reverse engineered the communications and dropped it into a nice Python script - web server included.


A program that lists as functional with Linux is Lightburn. It's new to the laser engraving world and supports GRBL type controllers as well as Ruida brand and possibly a few others. If you can determine your controller, you're a step ahead of the game.

Directly from their site:


LightBurn is layout, editing, and control software for your laser cutter. With LightBurn you can:

  • Import artwork in a variety of common vector graphic and image formats (including AI, PDF, SVG, DXF, PLT, PNG, JPG, GIF, BMP)

  • Arrange, edit, and even create new vector shapes within the editor, with powerful features like offsetting, boolean operations, welding, and node editing

  • Apply settings like power, speed, number of passes, cut order, brightness & contrast, dithering mode, and much more

  • Send the result directly to your laser cutter

LightBurn is a native application written for Windows, Mac OS, and Linux.

lightburn logo

I'm a satisfied Lightburn user, not a company representative.


Not a native Linux application so I dunno if it matches your use case, but the driver and control software "Laser engraving machine K4 V2.2" that was bundled with the printer on a USB stick works fine with Wine!

I'm running Debian Bullseye/Sid and I'm using version 5.0 of Wine. I started with installing the driver simply by running wine driver.EXE in the correct folder on the USB stick. The control software, however, seems to need .NET to run which it says by prompting you to install "wine-mono". After a bit of googling I found out that installing .NET using the command winetricks dotnet45 worked fine. After this you can simply run the software using wine Laser\ Framework4.exe.

I'm sure this is also doable using the GUI, but this is the way I did it. Also, maybe it works just as well with actually installing "wine-mono" instead of dotnet45 from winetricks.

EDIT: I can't find a license for the software on the USB stick, and I also can't find it online so I refrain from uploading it. OTOH, the USB stick is chock-full of logos of different brands so I doubt the authors are even aware of international copyright laws. Maybe I could send the software to you personally but I wouldn't host it since it could even contain malware


I also have one, when you plug it on your linux computer, there is a CH340G usb-serial chip inside, a serial port should be available at /dev/ttyUSB0, and you can send a right BMP file via this serial port.

Maybe EzGraver would work?


  • $\begingroup$ Hi, and welcome to 3DPrinting.SE! The OP tried EzGraver, but that did not work for him unfortunately. $\endgroup$
    – 0scar
    Jul 29, 2019 at 21:15

I have a similar machine and you won't find a Linux software to control it. You won't find a Windows software either, except the one shipped with the machine. I sniffed the traffic on the USB port and the control is proprietary.

The good news is the included software runs on Wine, but I did not get to serve the COM-port to the program. Under Windows, the driver fixes the port to COM4: but I did not find out what the exact name is (capitals or : or other parts) that the program expects to symbolicly link the port to /dev/ttyUSB0. You might have better luck. When sym-linking the port doesn't forget the permissions, that's another trap.


The best is Kiri Moto.

I use CNC and the stack idea is very comfortable. Laser and FDM, SLA are available as well.

  • 1
    $\begingroup$ Welcome to 3D Printing SE and thank you for your contribution. When you get a chance, please take the tour to understand how the site works and how it is different than others. $\endgroup$
    – agarza
    Sep 1, 2021 at 15:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .