I thought I have already had and fixed every problem one could possibly have with a 3D printer. Guess I was wrong.

I haven't used my Creality CR-10 for a few weeks, everything was working the last time I tried. Today I wanted to print something minor and the printer just randomly paused a few times in the middle of the print.

To be exact, it seems that after a few G-code commands have been executed the printer just freezes for like 10 seconds and then continues like nothing happened. This occurred a few times and every time the nozzle is melting the surrounding plastic and extruding a little which ruins the print.

I have tried:

  • Print from SD Card
  • Print from Laptop via USB connection to Ultimaker Cura
  • Print different models at different settings

My theory is that either there is a core problem with how Ultimaker Cura exports the G-code files or something is wrong with the printer software. I thought that maybe re-installing the firmware might fix it but I heard that that is a risky process. What do I do?

  • $\begingroup$ Is there any real problem with the print itself or does the printer miss steps when it does this? $\endgroup$ Jun 12, 2019 at 20:44
  • $\begingroup$ Is it randomly pausing, or after each layer? Maybe the minimum layer time setting has been changed by accident. $\endgroup$
    – 0scar
    Jun 12, 2019 at 21:33
  • $\begingroup$ Ok I fixed it by using Cura 4.0.0 instead of Cura 4.1. I checked again and found that the delay of ~10 seconds occurred every time right before the print head would go to a new object and again when it arrived. So when finishing the skirt it stops, when arriving at the new object it stops. I haven't found any setting that would cause this so I will try to make a bug report. $\endgroup$
    Jun 13, 2019 at 11:07
  • 1
    $\begingroup$ Have you examined the G-code? If there is a long sequence of "no-op" g-codes, or a pause command (G4) there would be a stop. Are you sure it has stopped? Perhaps it is moving slowly? The g-code would tell the tale. Is it possible that you have z-hopping turned on, and that the z velocity is extremely slow? I guess in summary I would examine the g-code. It is likely that the printer is behaving correctly, but the slicer is slightly misconfigured. $\endgroup$
    – cmm
    Jun 13, 2019 at 16:12
  • 1
    $\begingroup$ I am seemingly having the same issue only on Cura 4.3. There is no "Maximum Z Speed" anywhere on 4.3 so how can I fix this? As talked about above I just checked my "minimum layer time" and it is set to 10. I have also used another slicer and this same issue keeps happening it just messes up differently. I've also tried printing from SD card and OctoPrint. Same issue... How could this be my slicer if this same thing is happening on a different slicer than Cura? Please see also CR-10S Pro pausing and starting again. $\endgroup$ Oct 13, 2019 at 2:59

2 Answers 2


Edit: The z-hop problem has been fixed in Cura 4.2.

This is a known issue with Cura 4.1 when z-hop is enabled.

If you touch the z-axis motor frame while it is apparently stationary, you may feel it is actually moving.

The solution is to set a value (I used something like 250 in conjunction with an Ender 3) for the "Maximum Z Speed".

First you need to get the setting to be visible, so go to the "Settings" menu and choose "Configure setting visibility...":

Configure setting visibility dialog

Then in the "Print settings" panel:

Print settings panel

The full story is available on GitHub at [4.1 - current master branch] Z feed rates #5753.


I experienced the same with 4.1. Everything went back to normal after going back to 4.0 despite that all settings were identical as far as I could see. I compared the two g-code files using a simple file comparison tool. They were very different, hardly anything was the same. I still need to figure out what they mean. The model and thus the g-code files are far to large to go through. So, I will have to use a simple and small model to start unraveling what those differences mean.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .