2
$\begingroup$

I'm not talking about making something that's outright disproportionate of course. I've been working in Blender and I've use Absolute grid Snap to snap my vertices to the grid. The problem is that it (didn't seem) to always work perfectly for centimeters, and seemed to work better for meters. (edit: I've learned what the problem was and it was simply the placement of the vertices in side view, being at slightly different elevations. I'm going to emphasize that the difference was very slight. It was just enough to show up in the measurements. When I switched from front view to side view I was able to adjust the elevation to the grid and that fixed the problem.)

$\endgroup$
3
  • $\begingroup$ It should be ok. $\endgroup$
    – user77232
    Jun 21 '19 at 11:33
  • 2
    $\begingroup$ @user77232: That's not something you can say unconditionally. $\endgroup$ Jun 21 '19 at 12:14
  • 1
    $\begingroup$ Why not turn off GridSnap if your primary concern is the length of a feature, rather than the endpoints of the feature? $\endgroup$ Jun 21 '19 at 13:07
5
$\begingroup$

It depends on what you're working on. If you're producing mechanical/functional parts (even if that just means having to connect to one another or to some non-printed part), 3 mm (0.3 cm) error is almost surely going to prevent them from working. Even 0.3 mm error might be a problem.

If you're doing standalone prints that don't have to interface with anything else, e.g. art, non-articulated figurines, etc., then it becomes just a question of what's visually acceptable, and that's a matter both of scale and of the detail level you want. For typical tabletop-RPG scale, for example, most of the acutal visual features are going to be smaller than 3 mm, so that much error is not going to work out. It might work for large busts, though.

In any case, I would recommend trying to solve the underlying problem. Either change your grid snap, or work at a larger scale and just scale down the final model.

$\endgroup$
2
$\begingroup$

Welcome to the SE 3D Printing site. Your questions are also welcome, as well as your answers to your questions, and the questions of others.

I am not a Blender user. I use CAD systems because most of what I do I want to have a certain dimensional precision.

If the problem is as simple as "The overall object is designed to be 7.345 centimeters but I want it to be 7.000 centimeters," you can fix that when you print the model. Use the scaling feature of your slicer to scale by $(7.000/7.345)$ or $95.303\%$. It will print as the size you want.

The problem may be deeper, though, in that you may be having trouble setting points within the model where you want them. In that case, the snap-to-grid feature is distorting your model's appearance and geometry, and there is nothing you can do to fix it.

If it can't be fixed by scaling, I would suggest that you should either turn off the snap-to features or set up a grid that matches the granularity you actually want for your design.

$\endgroup$
1
$\begingroup$

After some trouble shooting I realized what was wrong, and now it seems more like a non issue if anything. There's actually nothing wrong with the grid, and the vertices were snapped to it appropriately in top view. The problem was that that my vertices were not at the same elevation (in side view). The two seemed very close to being snapped appropriately on the grid in side view which is why it wasn't immediately obvious.

$\endgroup$
1
  • $\begingroup$ Great that you found an answer. Don't forget to marked this as the accepted answer using the tick icon, so that it gets removed from the unanswered question queue. Thanks. $\endgroup$
    – Greenonline
    Jun 23 '19 at 9:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.