4
$\begingroup$

I just installed my (v3) BL Touch with a vanilla version of Marlin (1.1.9) on my Ender 3 and everything seems to work fine (including auto home) except the probing. It repeatedly does the first three probes (successfully) but then tries the fourth and fails. Even when disabling the axis movement (X/Y stepper motors) the issue persists, which would indicate that it is not a bad connection or physical location dependent. Any ideas on how to troubleshoot?

On second thoughts, it seems that it now fails inconsistently, so it is probably a wiring issue, although there is still the issue of it not retracting before printing and not leveling well when it does (although those issues would be more appropriate for a separate question), among other things.

$\endgroup$
  • $\begingroup$ Welcome to 3dPrinting.SE! $\endgroup$ – Pᴀᴜʟsᴛᴇʀ2 Jun 22 '19 at 16:13
  • $\begingroup$ This is a loose wire, may be some strength is pulling the wire while moving from XX,XY,YY then you get the failure. Also happens with the temperature sensor or even the heat resistor. Keep your wires tightened to connectors. $\endgroup$ – Fernando Baltazar Jun 24 '19 at 6:11
  • $\begingroup$ It also fails when disabling the X and Y motors, so I'm not sure if it's a pulling as much as a poor connection. $\endgroup$ – Blubberguy22 Jun 25 '19 at 11:26
  • $\begingroup$ Please post the solution as a separate answer, the text is still in the question, if you edit it it will become visible. You can even accept your own answer after 48 hours. $\endgroup$ – 0scar Aug 2 '19 at 5:00
1
$\begingroup$

Is your BL Touch a v3 (likely if you've only just purchased it)? If so, make sure you're using the bugfix version of Marlin 1.1.9, which supposedly fixes the compatibility issues. I say supposedly because there's also a capacitor on the mainboard that can be removed to fix the issue, and once I removed it (and commented out the specific v3 bits in the firmware) the BLTouch performed noticeably better than when relying on the bugfix firmware alone.

Teaching Tech on YouTube has a few BLtouch Ender 3 videos, covering the changes for configuring the bugfix firmware and the removal of the capacitor.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Oh yeah, I forgot about that. Yes, it is a v3, so the updated firmware should help with the other issues but I still think it also may be a wiring issue because of the inconsistency of failure. I just ordered a replacement so I'll update accordingly once I get the new one set up with the bugfix firmware. Thanks. $\endgroup$ – Blubberguy22 Jun 25 '19 at 11:24
  • $\begingroup$ I'd recommend getting ready with the bugfix firmware and the v3 settings it comes with ahead of time so that you can try it with the existing probe and wiring and be 100% sure that this wasn't the cause. $\endgroup$ – StringsOnFire Jun 25 '19 at 14:41
  • $\begingroup$ Good to see you solved the problem and took the time to share it with us! Please post your last edit as a separate answer posting to stick to the Q and A format of SE sites. Please accept your answer (after 48 hours) so that it does not pop up to the top of the queue once in a while. This also will help us in reducing the unanswered questions list. $\endgroup$ – 0scar Jul 31 '19 at 21:51
  • $\begingroup$ I followed the same guides and everything works now. I believe the bugfix firmware is what resolved the issue. Unfortunately I had returned the old probe so I wasn't able to test that but I did try different wires on it and it still failed, so that leads me to believe it was a software issue. $\endgroup$ – Blubberguy22 Aug 1 '19 at 15:21
0
$\begingroup$

I've been through the same sort of issues and eventually found that it was attributed by the cable and connector. Re-check or re-wire the sensor, this helped me out.

| improve this answer | |
$\endgroup$
  • $\begingroup$ I figured as much. I ordered a replacement, so hopefully that resolves the issues. $\endgroup$ – Blubberguy22 Jun 25 '19 at 11:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.