1
$\begingroup$

I have a Prusa3D i3m3s. The problem occurred once before with firmware 3.6.1. Last night I upgraded to firmware 3.7.1 and repeated the problem almost exactly.

The symptom is that at what appears to be the same point in the print in the two failure instances, the extruder stops extruding. There are a few wisps of filament on both failures. The print continues to completing. At the end of the print, the firmware issues an error because the MMU2s can not properly retract the filament.

On analysis, the filament is tightly jammed into the extruder and hot end, almost as if there has been heat creep. Slow, strong, and steady tension on the filament will withdraw it from the extruder system.

The hot end heats normally, and maintains temperature. When hot, plastic extrudes properly from the hot nozzle.

The thermister wires are damaged from an earlier problem.

The damage points to a thermister-related problem, but a shorted or open thermister is easy to detect in firmware. I would expect it to throw an error and stop the print.

My question is: Does the Prusa3D firmware detect open/shorted thermisters and stop the print?

If a photo is required, I can post that tomorrow.

$\endgroup$
3
$\begingroup$

This sounds like a problem I had with my hotend cooling fan a couple years back. To answer your question, from what I'm reading, the Prusa3D firmware detects thermal runaway if the hotend temperature drops for more than 45 seconds, it detects an open-circuit by reading 16 °C or less (MINTEMP error), and detects a short by reading 310 °C or higher (MAXTEMP error).

Couple questions that might help better troubleshoot the root of the problem:

  1. have you measured the thermistor's resistance while cold or hot?
  2. have you made sure your hotend cooling fan is at an appropriate speed while heated?
  3. have you made sure your print cooling fan duct isn't pointed at the hotend block due to being jostled?

You might find that there are some fairly simple solutions to a handful of overheat problems. I bought a cheap knockoff all-metal heatbreak and immediately ran into problems, but solved them by printing a better heatsink shroud and upgrading to a 40 mm fan. If you've upgraded to an all-metal hotend, you might run into issues with PLA specifically if you're not printing enough material fast enough, as PLA is somewhat sensitive to heat creep through the filament itself in the throat of the hotend.

| improve this answer | |
$\endgroup$
  • $\begingroup$ @NachOz, I was about to delete my question. The problem may have been in the slicing, although I didn't see anything obvious to me in the g-code. The curious part is that I had previously sliced the model to stop at a particular Z-height. It printed as it should. I then resliced the model for the full height, and the print failed at the point where I had stopped before. But, rather than a crisp end, it had filament wisps, and ultimately the extruder drive stripped the filament. Since I no further filament changes, it continued to "print" in the air for a few more hours until the end, ... $\endgroup$ – cmm Jul 1 '19 at 15:31
  • $\begingroup$ ... when it could not retract the filament. I carefully inspected the thermocouple wiring, and it was fine. I tried wiggling the cable assembly while the hot-end was hot and could see no variation. The fans are correctly placed, and seem to be appropriately blowing. I will look more at the g-code -- something may be hiding. +1 for answering. Under thermal runaway, does it stop the print or allow the print to continue? $\endgroup$ – cmm Jul 1 '19 at 15:35
  • $\begingroup$ To be honest I don't actually know the exact answer to that. I think when I was running repetier, it stopped the extruder from doing anything but allowed the printer to keep moving as if nothing had happened. I don't actually know what Prusa's firmware does, or even what it is. It still sounds to me like you've got some latent cooling issues. Do you have an enclosure for your printer, or an enclosing wall printing around it, and what is your bed temp set at? $\endgroup$ – Nach0z Jul 1 '19 at 18:33
  • $\begingroup$ The behavior is consistent with a thermistor error causing the heater to stop long enough for the hot end to cool below the flow temperature. Once the Bondtech gears have chewed through the filament, it isn't going anywhere. $\endgroup$ – cmm Jul 1 '19 at 22:30
  • $\begingroup$ Well, as a last resort you might try going and getting one of the latest Marlin releases, configurating it and uploading to your Prusa. You might get better information out of its thermal runaway and thermistor fault detection than you are out of the stock firmware. You might want to double check you can get the stock firmware back on the device afterwards first, and I know this is kind of a drastic step to take, but it's unlikely you'd see a "thermistor error" that isn't either open-circuit or closed-circuit, both of which would trigger the Prusa faults. Maybe thermal paste would help? $\endgroup$ – Nach0z Jul 2 '19 at 1:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.