See the pictures below. I have a severe under extrusion when the printer starts the outer wall, which is resolved by the time it finishes the outer wall. It starts the layer in the same place every time, so it results in this vertical line, on one side of which is fine (where it finishes the layer) and the other side has bad gaps and the wall is much thinner.

In this picture, the problem is on the outer wall (see red outer line, the print head is moving counter clockwise.

G-Code visualization

And here is the print showing the issue. Just fine on one side, but terrible on the other, precisely where it starts the layer. Strangely, this only occurs on the layers with infill. The top layers seem fine (despite starting in the same place). I have disabled retraction with no effect.

Here you can see it start at the tip and get gradually better as it progresses. enter image description here

Here you can see that by the time it finishes, it's just fine, and also what a contrast is between the start and end. That should be a flush edge, there. enter image description here

Another view enter image description here

Is there some setting that I should be tweaking? I've exhausted my own ideas of different tweaks to no avail.

The printer is a Monoprice Maker Select V2. I'm using Ultimaker Cura 4.1.0.

  • Material: PLA
  • Layer height: 0.24 mm (in the pictures, but replicated with 0.16 mm also)
  • Temp: 205 °C, here (but tweaking this hasn't had any effect)
  • Retraction: Disabled

This doesn't happen on layer changes. Although it does line up with the Z seam, you can see from the G-code visualization below that the outer wall is the very last thing it does. The issue occurs at the start of the outer wall (still on the same layer) that it has the issue, but by the time it ends the wall (just before switching layers) it is fine.

I've tweaked a few other settings, one by one, and seeing if any have any effect. So far, not really:

  • Outer Wall Wipe: 0.2 (default), 0.8, 0.0
  • Jerk Control - Wall Jerk max velocity change, 5 mm/s
  • Outer Wall before inner (Yes instead of No)
  • Wall Line Count (3 instead of 2): This improves it some, but I suspect just by making it a little more difficult to see

What have I done since...

I reset all settings in Cura to a default "Draft" setting and then set layer height to 0.24 mm, and turned off Infill. Then I have tried prints with different settings for "Retract Before Outer Wall" and printing temperature.

Here are those results:

These pics seem to suggest a very clear lag in extrusion. 1 and 2 are different temps. 2 and 3 are different retraction.

205 °C, 0 % Infill, Retract Before Outer Wall: Off 205 Celsius, 0 Infill, Retract Before Outer Wall: Off

195 °C, 0 % Infill, Retract Before Outer Wall: Off 195 Celsius, 0 Infill, Retract Before Outer Wall: Off

195 °C, 0 % Infill, Retract Before Outer Wall: On Note: the retraction setting resulted in a noticeable pause before printing the outer wall. Retraction distance is 6.5 mm, and this is not a Bowden fed device. 195 Celsius, 0 Infill, Retract Before Outer Wall: On

There doesn't seem to be anything strange about the G-code, either. Here are the G0 travels just before the outer wall followed by the wall.

G0 F7200 X106.319 Y93.413
G0 X106.26 Y93.909
G0 X107.213 Y93.658
G0 X107.8 Y92.542
G0 X107.286 Y90.844
G0 X107.509 Y90.394

; (outer wall of outside)
G1 F1328 X107.985 Y90.707 E116.98713
G1 X108.38 Y91.128 E117.01098
G1 X108.658 Y91.623 E117.03444
G1 X108.813 Y92.18 E117.05833
G1 X108.832 Y92.751 E117.08193
G1 X108.713 Y93.315 E117.10575
G1 X108.463 Y93.837 E117.12966
; (first curve complete, on to straightaway)
G1 X99.631 Y107.716 E117.80936
G1 X98.912 Y108.59 E117.85612

Even more done...

These are retraction off, and 205 °C

If I set the "print speed" in Cura to 20 mm/s (normally 60 mm/s), the outer wall speed is reduced from 30 mm/s to 10 mm/s. The result is quite good. enter image description here

If I leave the "print speed" at 60 mm/s and adjust only the outer wall to 10 mm/s, it's still quite good. enter image description here

So it seems like an acceleration thing. If I can figure out how to get it to slow down in just the right spots or compensate in some way, then perhaps I can make this problem go away with minimal sacrifice in total speed.


8 Answers 8


Based on other comments, answers, and question edits so far, in addition to your original question, I believe there are possibly two things going on here: incorrect retraction settings, including a misunderstanding of which settings are relevant and what they do, and issues related to slow acceleration. Both relate to misdepositing/loss of material.

First, some basics. When the filament is advanced to the point needed to extrude material and print at the intended volumetric rate, it's under significant pressure, compressed between the extruder gear and the nozzle. My understanding is that your printer has a direct drive extruder, not a bowden, so there's far less compression than with a bowden setup but it's still there. This means that, if you try to stop extruding, it's material will continue to come out of the nozzle, just at a decreasing rate, until the pressure dissipates. This effect is reduced but still present if the nozzle is held-against/moving-over already printed material, and heavy if moving over empty space, even moreso if moving across sparsely-filled space like infill where it will bond with the already-deposited material and get "stretched"/"pulled" out.

The idea of retraction is to pull the filament back when the print head is moving to a new location without trying to deposit material, to relieve this pressure and prevent unwanted misdepositing/loss of material, and to reverse the process, putting the filament back exactly where it was when the last printed line ended, the next time it starts trying to deposit material.

The relevant options in Cura are:

  • Enable Retraction - must be on
  • Retraction Distance - should be at least 5-6 mm for bowden setups, probably more like 0.5-2 mm for direct drive.
  • Retraction Minimum Travel - should be 0
  • Combing Mode - try different settings. Off is probably the best relative to your issues, but hurts your print time a lot for certain models, and can hurt quality in other ways.

Everything else related to retraction is fairly irrelevant, especially "Retract at Layer Change" is a niche option and not typically useful. As I understand it, turning just "Retract at Layer Change" on does not mean retraction is on.

Now, your other issue may be acceleration. Extrusion works best as acceleration speed approaches infinity, because the extrusion rate and pressure needed to extrude will be fairly constant for the entire line/curve. If acceleration is very slow, pressure will be wrong during the start and end of lines. It's likely that, due to high pressure, excess material will get deposited at the end of one line while slowing down, then after moving to start the next line, even if you retract the filament, you'll have insufficient pressure at the nozzle after reversing the retraction to start the next line.

A jerk limit of 5 mm/s is really low. I'm used to more like 20-30 mm/s. You don't say what your acceleration limit is, but it's probably also low. Slow acceleration has minimal impact if your max speed is slow, because you quickly reach the max speed and most of the print speed (and thus extrusion rate) is steady. But if you want to print at high speeds, you need high acceleration. Try and see if you can increase it. Or accept printing at slow speeds.

Another option, if you're open to hacking on your printer, is replacing the stock firmware with a recent version of Marlin with the Linear Advance feature. It does the math to model the filament pressure as a spring, with a spring constant you can tweak, so that it can compensate for varying print speed and end lines with approximately no pressure remaining.

  • $\begingroup$ I have managed to reproduce this behavior under much more controlled conditions and was able to definitely see that the issue is plastic leaking out of the nozzle during travels. The longer the travel, the longer the under-extrusion persists once printing resumes. This was also correct: "including a misunderstanding of which settings are relevant and what they do". In particular, retraction in Cura only occurs when traveling outside the model. If you want retraction at other times, there are other settings for this. I still have not found the best settings, but I'll work on it further. $\endgroup$
    – Warren
    Aug 5, 2019 at 17:06
  • 1
    $\begingroup$ @Warren: "Combing" is what prevents retraction from happening inside the model. I have an open issue with CuraEngine which explains a lot about what might be going on for you: github.com/Ultimaker/CuraEngine/issues/1084 $\endgroup$ Aug 5, 2019 at 17:28
  • $\begingroup$ In the absence of a fix for that issue, if you're getting oozing inside the infill area and it's causing problems, you probably just need to turn combing off entirely. If you do that, it might help to increase min retraction distance from 0 up to roughly your nozzle size or slightly larger (maybe 10-25% more); otherwise you can get retractions at each line direction reversal on top/bottom "skin" fill and the print will be very slow. $\endgroup$ Aug 5, 2019 at 17:31
  • $\begingroup$ I disagree on the "Retract at Layer Change" being "not typically useful". The setting "Wall ordering Outside to Inside" can be beneficial wrt. visual surface quality. But if enabled, it is not uncommon for a new layer to start on a visible outer wall. In which case retraction is often necessary to avoid oozing. Similarly, the setting "Retract Before Outer Wall" can also be necessary to force retractions. Also worth mentioning (to debug surface defects) is that the layer preview shows retractions: dark blue travels are without retraction, vs light blue travels do have retraction. $\endgroup$
    – JRTG
    May 16 at 13:05
  • 1
    $\begingroup$ Another relevant setting is "Max Comb Distance With No Retract": by default, for 'combing travels' no retraction is done. With this setting retraction can be enabled also for combing travels if they are longer than the set value. $\endgroup$
    – JRTG
    May 16 at 14:00

As @user77232 points out, you may have a general flow rate issue which can be adjusted in your slicer.

However, it looks like your machine might be retracting during some of the center layers. Notice the first few layers extrude relatively normal, then it under extrudes, then it goes back to relatively normal a few layers before a ceiling. Also note that the under extrusion seems to stop exactly where the z-step occurs (see the z-step seam).

This link shows that it's possible it could be your retraction settings before each layer. I'm not sure what it is with Cura, but in MakerWare and older slicers you could specify a retract distance before each layer. I would try reducing this. Also, these older slicers had different retract rates/distances for bases, floors, main wall, supports, bridges, top layers and more. So, this could be why you have different results throughout Z in your part.

  • $\begingroup$ Although it does line up with the Z seam, you can see from the G-code visualization above that the outer wall is the very last thing extruded in the layer. The issue occurs at the start of the outer wall (still on the same layer) that it has the issue, but by the time it ends the wall (just before switching layers) the issue is gone. This does look very much like the images in that link, I'll go read through that more closely. Retraction was promising, but I tried disabling retraction entirely and it had no effect. $\endgroup$
    – Warren
    Jul 27, 2019 at 0:42
  • $\begingroup$ Physically, how would retraction make this happen? Retraction prevents losing material; it shouldn't be able to cause it. $\endgroup$ Jul 27, 2019 at 13:17
  • $\begingroup$ @R.. Maybe I've been misinterpreting the setting, but I thought retraction was where the machine physically retracted the filament (running the stepper in the reverse direction) to avoid additional "ooze" or stringing at the end of each path. So, if your machine is actively retracting too much filament or too early, then you end up with the results seen in the images. $\endgroup$
    – tbm0115
    Jul 28, 2019 at 2:42
  • $\begingroup$ @Warren Firstly, your photos are great, very helpful. I still think your initial issue was a retraction issue. If you slicer is retracting too much or too early, there may not be enough pressure built up in your nozzle, so starting your next layer may become "stringed" as filament+pressure builds up in your nozzle. The Z seam definitely warrants its own question though if you're looking to further improve your prints. $\endgroup$
    – tbm0115
    Jul 28, 2019 at 2:50
  • 1
    $\begingroup$ Aside from being unsightly and possibly contributing to weight imbalance on prints where it matters, oozing causes there to be a deficiency of material deposited immediately after the travel where the ooozing occurs, and unless you can accurately model the oozing mathematically, there's no way to adjust extrusion to compensate for it, and there'll be insufficient (if you don't compensate) or too much (if you try to compensate but do too much) material deposited for a while after the travel that oozed. $\endgroup$ Jul 28, 2019 at 3:57

From the sliced image you it appears as if long travels are present. High temperature (205 °C is on the upper side for PLA) slow travel moves and long moved allows filament to leak out into the infill region. Once it reaches the outer perimeter, there is not enough of liquid filament available and it will start under extruded.

Lower temperature with 5 °C increments (down to 195 °C) and increase travel speed with increments of 10 mm/s.

  • $\begingroup$ This should not happen unless retraction length is too low. I suspect OP has something else wrong. $\endgroup$ Jul 27, 2019 at 13:20
  • $\begingroup$ @R.. the OP has no retraction set, so this is perfectly viable. $\endgroup$
    – 0scar
    Jul 27, 2019 at 14:35
  • $\begingroup$ Indeed. I read "I have disabled retraction with no effect" as saying the OP was first trying with retraction, and turned it off to see if that would help (should expect the opposite ¯\_(ツ)_/¯). But indeed if retraction was always off or was low to begin with and then turned off, this is almost surely the problem. $\endgroup$ Jul 27, 2019 at 17:21
  • $\begingroup$ I wouldn't call 205 high for PLA though. I print PLA at 210 (215 first layer). I might try to see if lowering the temp is viable now that I have firmware with linear advance though; I suspect adjusting the spring constant could make up for difficulty extruding at lower temp. $\endgroup$ Jul 27, 2019 at 17:23
  • $\begingroup$ I have now printed at 195 and 205 and with "Retract Before Outer Wall" on and off. The temperature has no discernible effect on this issue. The retraction, when on, definitely seems to make the issue much worse. I will add pics of these. $\endgroup$
    – Warren
    Jul 27, 2019 at 17:26

I experienced almost the exact issue printing PETG, where severe under extrusion happens at the start of a new layer.

After going though the tool path in Cura I determined that the root cause of this is because the last printing step at each layer is to fill the small gaps. The extruder would extrude very little material while going though the small gaps in the printed layer. The melted plastic in the print head would get dragged out, therefore more material would be lost than what was accounted for in Cura.

Because of the uncertainty of how much material would be lost in the process, there is almost no way to compensate for it. The best "solution" I came up with is to add a small sacrificial cylinder to the model. The printer will fill the small gaps in the main object, then print the dummy cylinder and then print the next layer. This completely eliminated the under extrusion problem at the expense of a bit more material usage. Of course the printed sacrificial cylinder would look really bad with severe under extrusion at the z-seam.

I believe the same solution will also fix your problem: just enable printing outside wall first, and add a dummy cylinder to your model.

  • $\begingroup$ Welcome to 3D Printing SE and thank you for your contribution. When you get a chance, please take the tour to understand how the site works and how it is different than others. $\endgroup$
    – agarza
    Jul 29, 2021 at 1:40

The problem seems to occur in the same area; along the z axis. You also seem to have an elephant's foot from the first layer being squashed. Change the flow rate in the slicer. Re tram (level) the bed and clean your nozzle.

  • $\begingroup$ The issue occurs where the outer wall starts, and that happens at the same X/Y coordinate, so it does cause the issue to align on the Z axis, however, to be clear, it isn't happening on the layer change, since that happens at the end of the outer wall at which point the issue is not there. I've tried different flow rates. I have suspected a nozzle issue and tried cold pulls etc to clean it, but also the sheer consistency of the issue makes me doubt that it could be any sort of clogging of the nozzle. $\endgroup$
    – Warren
    Jul 27, 2019 at 0:50

I was experiencing exactly the same problem (CR-10S, Cura 4.5, all mechanical issues fixed, new nozzle, new fans, good quality PLA), I would like to add one observation that might contribute to a solution (yes, I know this thread is old but many people are still experiencing this issue (a lot actually) any everybody seems to be stuck in the "you need to level your bed" loop) but this discussion here is going beyond this and is by far the most constructive I have seen so far:

Ok, here goes: when measuring my hotend with a thermocouple probe (Uni-T UT320D) right behind the nozzle (after removing the Bowden tube), I can observe a significant deviation between the displayed temp (= the same one I entered in Cura) and the temperature the filament gets to see. This is around 20 °C in difference @ 200 °C, meaning a setting of 205 °C is actually closer to 185 °C. For the bed the offset is only 1-2 °C. After swapping the glass bead NTC just for fun (Ohms were OK) ...nothing changed. Others have observed this offset in CR10 machines as well (original firmware).

Combined with the fact that we CAN produce nice prints at insanely slow speeds (10 - 20 mm/s), this somehow gives me the feeling that some bug (somewhere) has reduced the heating capacity of the hotend in the affected machines / set-ups... Now this could be a parasitic loss due to a bad connection somewhere but this would quickly lead to other problems (fire) as well (which it didn't - at least in my case).


What worked for me was enabling outer wall wipe distance to around 3 mm, that's all that I enabled and it instantly fixed it, no prime amount or anything, just outer wall wipe distance


try retract before outer wall off.

  • 1
    $\begingroup$ Hi and welcome to SE 3D Printing! Whilst your answer may be technically correct, it is lacking detail, and, as such, it has been recommended for deletion, unfortunately. If you could expand it then you may get a more positive response. I would recommend that in addition to reading some highly voted answers to gauge the standard expected, that you take a look at the help section relating to answering questions, in particular How to Answer, and take the tour for more information on how stack exchange works. Thanks :-) $\endgroup$
    – 0scar
    Feb 5, 2021 at 21:05
  • 1
    $\begingroup$ As stated in the question, the OP already tried that. $\endgroup$
    – 0scar
    Feb 6, 2021 at 11:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .