2
$\begingroup$

I have been messing around trying to flash marlin 1.1 onto my Arduino Mega 2650 and RAMPS 1.4. I have Managed to get it to upload fine however it will not upload with the LCD I want. I am trying to upload it and have it set to a "RepRap Discount Smart Controller". When I uploaded the firmware it was on the stock Anet LCD, however when I try to change this in the file and verify it I get an error that I do not understand. I have done some digging on google but haven't really been able to figure out the answer. Here's the error:

sketch\ultralcd.cpp:4860:3: internal compiler error: Segmentation fault

   DEFINE_MENU_EDIT_TYPE(uint32_t, long5, ftostr5rj, 0.01f);

   ^

Please submit a full bug report,

with preprocessed source if appropriate.

See  for instructions.

lto-wrapper.exe: fatal error: C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.21.0_x86__mdqgnx93n4wtt\hardware\tools\avr/bin/avr-gcc returned 1 exit status

compilation terminated.

c:/program files/windowsapps/arduinollc.arduinoide_1.8.21.0_x86__mdqgnx93n4wtt/hardware/tools/avr/bin/../lib/gcc/avr/5.4.0/../../../../avr/bin/ld.exe: error: lto-wrapper failed

collect2.exe: error: ld returned 1 exit status

exit status 1
Error compiling for board Arduino/Genuino Mega or Mega 2560.
$\endgroup$
6
  • $\begingroup$ Which LCD are you connecting? The discount controller uses the EXP1/2 ports, the Anet uses AUX2. See e.g. this answer; these LCD's require totally different solutions. Please make the question a bit more clear on what you have and what you connect. $\endgroup$
    – 0scar
    Aug 2, 2019 at 11:37
  • $\begingroup$ Im using a reprap discount smart controller. The marlin setup is far an abet a8 but I changed the motherboard to ramps_14_efb. I have been fallowing a tutorial online that said I only had to comment the stock ante screen and uncomment the reprap discounted smart controller line. However when I do so it gives me the error up above. I hope this clears it up if nto please let me know and I will try to clatter further. $\endgroup$
    – Rocket_Man
    Aug 3, 2019 at 1:02
  • $\begingroup$ It appears that I am trying to do the exact opposite of the answer you linked me to. Rather than trying to run it off of the ante lcd I want to run it off of the reprap lcd however when I uncomment the line to do so it gives me an error I don’t understand. $\endgroup$
    – Rocket_Man
    Aug 3, 2019 at 1:06
  • $\begingroup$ Try running as admin. That error doesn't seem to be strictly firmware related. $\endgroup$
    – towe
    Aug 6, 2019 at 7:23
  • $\begingroup$ Sorry I’m really new to the programming side of it. Can you explain what running it as admin means? $\endgroup$
    – Rocket_Man
    Aug 7, 2019 at 8:20

1 Answer 1

2
$\begingroup$

Running it as admin fixed the issue.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .