3
$\begingroup$

Running on the Marlin 1.1 firmware, for this issue, most other variables of the printer can just be assumed (It's a CoreXY design, but think i3 for my current testing). (Highlighted my only lead in bold, so probably best to read that first)

The problem: X-axis stepper driver and motor moves fine, all other axis's don't.

What I've tried and deduced.

  1. I've inverted all endstops and ruled out end stop errors, as well as any warnings that get reported through serial.
  2. Swapped stepper drivers from the Y axis (just focusing on the Y axis for now) to the X axis, the X axis is still the only one that moves.
  3. Swapped the X and Y axis motors: only the Y axis motor works, so still only getting powered from the X axis driver
  4. Tested power on the stepper drivers, all stepper drivers get the same motor and logic power within margin of error
  5. Tested step signal on the Y axis with an oscilloscope, found my only lead, when moving the X-axis, the step control has a peak voltage of ~5.2v and the motor moves. When testing the Y axis, the step input voltage from the Arduino to the driver has a peak of ~1.7v
  6. Assuming something may be wrong with the connection, I tested the resistance between all step pins from the Arduino side to the stepper driver itself and got a constant resistance of 2.5 ohms for all drivers, pins are connected properly.
  7. Pulled the Arduino out, uploaded and ran a custom servo script on it, using pin A6 as the PWM control signal. Server runs fine with the correct voltage (ruled out a microcontroller issue).
  8. Reassembled the RAMPS, motors etc, reuploaded a fresh copy of Marlin from their site that I configured from scratch and did some extra probing around to make sure all the connects are fine, still, only the X-axis works.
$\endgroup$
  • $\begingroup$ Do you own an oscilloscope or could you use a sound card as one so we can generate some readings together? $\endgroup$ – harmonica141 Aug 14 '19 at 10:23
  • $\begingroup$ I own a full digital storage oscilloscope, though I replaced the stepper drivers and all of the axis work now. turns out the one was partially shorting the digital pin causing the remaining drivers to lose power. So glad I figured this out before buying a new logic board. $\endgroup$ – Snickers Aug 14 '19 at 23:59
1
$\begingroup$

Turns out there were multiple faulty stepper drivers, if the one stepper driver was plugged in, it would operate, but would draw too much current from the pins on the Arduino causing all the other drivers to receive weak signals.

This is why swapping them around still only worked on the X-axis, if it was only one driver, I would have figured it out.

So if you get a very weak signal on the stepper driver step pin, even when it's pulled out, it's probably because of one of the other stepper drivers shorting the whole rail.

|improve this answer|||||
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.