My CR-10 printer seems to be trying to print the model 4 or 5 layers too low. This means that for the first few layers, the printing nozzle is forced against the bed, preventing extrusion until the print reaches higher layers.


This results in the bottom part of the print having the internal structure visible and the printing head deteriorating. I had to remove the old nozzle because it was clogged up with what I believe to be some residue that was picked up during preceding prints.

A print showing the structure inside the model because of missing layers note: On this print, the top part is almost-well printed. It cannot be seen in pictures, but I say "almost" because the well-printed part is still much thinner than expected. This is the result of my purposeful mis-leveling the bed so that the part where the printer "homes" is higher than the lower part. I did this to see if there was any obvious bending of the printing bed. Doesn't look like there is.

Fix attempts

  • I have tried to re-level the bed multiple times, but it doesn't matter as the "too low" effect is independent from the location on the bed.
  • I have tried using the printer's built-in Z-offset but to no avail. This might be due to the fact that I control the print through Ultimaker Cura 4, so I tried looking for the Z-offset property in Ultimaker Cura and even though internet says it exists, I failed to find it.


The printer used to work perfectly well and I do not remember having changed anything before the problem arose. I recently changed the nozzle and made sure to tighten it as high as possible but the Z-offset problem still persists.

  • $\begingroup$ what is the thickness of the first layer? I use 0.2 mm for it to ensure I don't 'squish' it too much $\endgroup$
    – Trish
    Aug 12, 2019 at 17:17
  • $\begingroup$ For my on-going print 0.16 mm I've tried several layer thicknesses, it doesn't seem to affect the offset problem :-/ $\endgroup$ Aug 12, 2019 at 17:38
  • 2
    $\begingroup$ Have you checked that everything is still assembled correctly? For example, the z-axis screw connector might be a bit loose, or the bed might wobble, or the z-axis stop microswitch asembly could be loose. $\endgroup$ Aug 12, 2019 at 18:21
  • $\begingroup$ Thank you all for your time, I fixed it. See my answer below for a good laugh at my lack of understand how a CR-10 works -_- $\endgroup$ Aug 12, 2019 at 21:43

2 Answers 2


Did you verify the Cura z-offset actually changed the corresponding G-Codes?

I had the opposite problem on my RF1000. To fix the problem I added the following 2 lines to my start G-Codes:

M3001 ; Activate Z-Compensation 
M206 Z-0.3 ; Set z offset 0.3mm closer to the nozzle

The first line was default in some example prints and is (as far as I know) only used by Renkforce printers. The second line moves the nozzle closer to the bed. In your case you'd have to move it further away and would need a positive Z value.

  • 1
    $\begingroup$ Was in the process of trying to send these GCodes to cura, so to decide what value to give it decided to watch the printer while it did a "auto-home" to guess the needed distance. Then when I realized what the problem was and wrote my answer below. To thank you, your answer led me to fixing this non-problem :-) $\endgroup$ Aug 12, 2019 at 21:42

TLDR; Make sure the bed isn't too high, the z-axis should reach the end-of-rail indicator without forcing against the bed

So it appears I simply misunderstood (or mis-assumed) the way my printer works.

For some reason I believed that it was the printing head, while auto-homeing, that was defining the "point zero" for the z axis. Didn't realize, even after disassembled the whole head block, that there was no such mechanism built in.

While zeroing it before starting my on-going print I noticed the "click" of the end-of-rail switch for the z-axis while the head was forcing against the bed, desperately trying to reach that damn switch. Then it all clicked together ...

What happened:

For some reason a few weeks ago I decided to level the bed by raising the z-axis by spinning the its driving wheel by hand, taking it very far from the end-of-rail stopper. Ever since then I've been leveling the bed this way, not realizing I was preventing the head from reaching end-of-rail without having to force against the bed.

So yeah, just took the bed as far down as possible, made the printer auto-home and leveled the bed from there, as it should be done, and my print is now going very well.

  • $\begingroup$ One thing to watch out for is, if the z-axis limit switch ("end-of-rail indicator") assembly is fastened to the vertical member in the same way as it is on the Ender 3, it can be tricksy in how the lock nuts seem to be locked when you tighten the screws but aren't when you need them to be. $\endgroup$ Aug 13, 2019 at 20:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .