1
$\begingroup$

Temperature is showing about 680 °C at room temperature. When I make it "hotter" by holding my thumb and index finger on it, the temperature does increase. So it is responding to temperature changes.

I'm trying to add some thermistors to my MKS GEN L v1.0 board:

MKS GEN L v1.0 schematics

I'm using the A11 pin and GND in the picture above.

The thermistor works correctly when plugged into the HE1 temperature pin. So the thermistor is fine hardware-wise.

The thermistor is set to be the "Chamber" thermistor in Marlin 1.1.x. This just means it is supposed to record the temperature of the enclosure. I don't know if there is some kind of volatility issue with the chamber constant in Marlin.

The thermistor has the same settings in Marlin for both HE1 and the chamber one. They are both set to "thermistor 11" for the 3950 type of thermistor. So the most visible setting implies they should be treated the same firmware-wise.

I've also tried the other extra Analog pins in the AUX-2 port.

What could be the issue here?

If these are the only available analog pins, how can I add more thermistors to my set-up so that they're available in Marlin?

Is there any way I can use the AUX-1 port? It doesn't seem to be an analog pin like in the photo for this particular version of RAMPS. I tried pin A3 but it didn't work.

| improve this question | | | | |
$\endgroup$
  • $\begingroup$ In my experience I had reading of about 700 degree when thermistor was somehow shorted to aluminium block together with heater cartridge. Basically the screw that hold thermistor is pushing too hard on thermistor wires. $\endgroup$ – Serge Rabyking Aug 31 '19 at 11:39
2
$\begingroup$

Thermistors, commonly used as temperature sensors on 3D printers and other DIY things, work by changing their internal resistance depending on the temperature.

On the analog ports, the microcontroller can determine the voltage of the connected signal.

To actually measure the resistance - and thus temperature - of the thermistor, you need to build a voltage divider:

Voltage Divider. Source: circuitdigest.com

Most, if not all, 3D printer control boards use a resistor of 4.7 kOhms and a capacitor to build this voltage divider:

RAMPS schematic. Source: reprap.org

You'll need at least this 4.7 kOhm resistor to get your thermistors working on any analog pin, if the three thermistor ports on the MKS Gen L don't suffice for you needs. You could also use other temperature sensors, especially for the case, like the DHT11 or DHT22, however I couldn't find whether they're supported by Marlin yet.

| improve this answer | | | | |
$\endgroup$
  • 1
    $\begingroup$ For those not having a great background in electrical engineering, you might want to explain to others why the RAMPS 1.4 shield doesn't use 2 resistors for the divider (like in your picture), but a 2 resistors (including the thermistor) and a small 10 uF capacitor (infinite resistor), please explain. $\endgroup$ – 0scar Aug 29 '19 at 9:39
  • 1
    $\begingroup$ @0scar The thermistor takes the place of R2. The capacitor may be for smoothing the output signal. I don't think it's intended use is to pull the voltage low for a short time when the unit is switched on, although it will have that effect. Or maybe it is, because the signal will end up at Vcc and the software could use that to detect if there is no thermistor connected. $\endgroup$ – Andrew Morton Aug 29 '19 at 9:51
  • 1
    $\begingroup$ @AndrewMorton I understand, but thanks for filling in the blanks for others, the comment was meant for the author to update the answer, you can also add this information by updating the answer. Comments are meant for questions so that the answer can be updated. $\endgroup$ – 0scar Aug 29 '19 at 10:48
  • 1
    $\begingroup$ @0scar Do you happen to know the purpose of the capacitor, so I could make a correct update to the answer? $\endgroup$ – Andrew Morton Aug 29 '19 at 12:58
  • $\begingroup$ I don't totally understand how it is smoothing the signal either. I wanted to say it is acting as a low-pass filter, but after looking at the circuit, the resistors/capacitor is divided over the signal. $\endgroup$ – K Mmmm Aug 29 '19 at 13:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.