2
$\begingroup$

I'm trying to print an architectural model of a house with 2 floors and a room on the roof. It was designed in SketchUp by a friend. I removed inner walls and floors to print it upside down to get just the outer look of that building. All is good in SketchUp and in Meshlab (converted .skp to .3ds) and even after exporting it to .stl format. But when I slice it and select preview, it is adding a floor on its own. Please take a look at the attached screenshots to get a better idea of what I am referring to. Any idea what's causing this and how it can be solved?

Prepare.png shows model before slicing

Preview.png shows model after slicing

(Using Ultimaker Cura 4.1.0 for slicing at 0.2 mm layer height)

$\endgroup$
  • $\begingroup$ Welcome to 3dPrinting.SE! $\endgroup$ – Pᴀᴜʟsᴛᴇʀ2 Sep 14 '19 at 12:45
  • $\begingroup$ I don't think your STL file is okay, it appears that you removed the floors, but there might be some problems with the normals of the faces. Maybe you can fix the file through NetFabb. $\endgroup$ – 0scar Sep 14 '19 at 12:59
  • $\begingroup$ Check the setting in the slicer for adding supports. Your overhand will be difficult to print. $\endgroup$ – Perry Webb Sep 14 '19 at 13:36
  • 1
    $\begingroup$ you can, in the preview, disable viewing the normal material and just display supports. Could you share a picture of that, so we get a better clue what type of print cura generates for you? $\endgroup$ – Trish Sep 15 '19 at 9:24
  • 1
    $\begingroup$ When I printed a similar house model designed in SketchUp, the generated .stl was of horrible quality. Windows 10's build in "3D Builder" has a very powerful .stl repair tool built in, which got rid of the defects. $\endgroup$ – towe Sep 16 '19 at 8:02
1
$\begingroup$

SketchUp has a problem with generating the normals of an STL in the right way. As you see in the slicer, the model claims, that the "tops" are overhangs, which means that the whole model is "inside out" with the normals.

To fix that, you'd need to open the file in a program that can fix that by recalculating the normals. I suggest blender:

  • Open Blender
  • Delete the cube by clicking on it and pressing the delete button
  • Import the STL via Drag & Drop or the menu
  • Change to edit mode in the top left corner
  • A to select everything
  • Ctrl + N to recalculate normals
  • N then under Mesh Display > Normals hook Faces

Now, your model should look like a hedgehog, each face having a blue line poking out.

It also should show if there are any faces remaining, which can be selected and deleted manually by clicking it, so that only it is highlighted, and then pressing delete

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.