1
$\begingroup$

On an Ender 3, the X, Y and extruder are not moving when using the prepare menu to move them. If I change the motherboard port for Y to the Z port, the Y moves fine, same goes for the other axis that are not working in their respective ports - so it's not the motor or the cable. What else could be wrong? I find it unlikely that 2/3 axis and extruder are all stopped working at the same time.

I have tried "auto home" but before anything moves it says "Homing failed PRINTER HALTED Please reset". The y axis seems to have a light humming noise to it, but no movement at all.

Seems like all of the stop switches are being ignored. When I "Home Z" with any stop switch plugged into the Z-stop, it just continues along even when i trigger the stop manually. This eventually means it hits the end of the axis and just keeps hitting the end with a nasty vibrating sound.

It was working for about 6 months before all this and my old power supply popped, replaced the power supply and all this started.

I have tried a pre-built marlin 1.1.9 firmware, then tried a self-built marlin 1.1.9 firmware that I followed a guide to do specifically for the Ender 3 and then flashed TH3D U1.R2.15 unified firmware using their instructions and still the problem persists through all firmwares

$\endgroup$
  • $\begingroup$ Hi and welcome to 3DP.SE! You basically established that X and Y only work on the Z header. Have you checked the endstops (e.g. inverted logic or incorrectly wired; try pressing an endstop switch when moving the axis, also note to home the printer first)? Also note that the extruder will only move when it is above a certain temperature, usually over 170 ºC. Please update your question by edit to include additional information that is asked through the comments. $\endgroup$ – 0scar Sep 17 '19 at 6:42
  • $\begingroup$ also, how long did you have the printer running beforehand? $\endgroup$ – Trish Sep 17 '19 at 8:59
  • $\begingroup$ updated the question with the answers to your questions, thanks! $\endgroup$ – Tim Fenton - VenumX Sep 17 '19 at 16:00
  • $\begingroup$ It sounds to me like the firmware may have become corrupt when the power supply popped... It's the only thing I can think of that would cause this bizarre behaviour! If you have an Arduino there are plenty of tutorials that explain how to reflash the firmware. $\endgroup$ – BG100 Sep 17 '19 at 18:00
  • 1
    $\begingroup$ Maybe the question should be: "Is it possible that blowing my printers power supply wrecks up my printer?" $\endgroup$ – 0scar Sep 17 '19 at 20:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.