My Anet A8 printer will not print over the heated bed.

Once I have prepared a file on Cura and inserted the SD card into the printer, the nozzle (extruder) moves into the top left corner and stays there. I have unchecked "Origin at center" and been over the printer settings multiple times. Yet still nothing.

Any suggestions?

I have included a picture of the settings I am using:

Settings for Anet A8

The second image shows the {speed_print} without any values

  • $\begingroup$ Welcome to 3DPrinting.SE! Please post a piece of the code (30 lines or so), or a link to PasteBin. $\endgroup$ – 0scar Oct 1 '19 at 13:13
  • 1
    $\begingroup$ What parameters did you use in your slicing software? Sure looks like the location data "thinks" the bed is off in negative (x,y) space somewhere. Make sure Cura knows you are using an A8, and that you have the X and Y motor drives plugged into the correct outputs on the board. $\endgroup$ – Carl Witthoft Oct 1 '19 at 13:48
  • $\begingroup$ Please fix your start and end codes by reading this question about not using G28 X0 Y0, use G28 in the start code and G0 X0 Y0 in the end code. Also remove the G28 Z0 from the start code. $\endgroup$ – 0scar Oct 1 '19 at 21:03
  • $\begingroup$ I have altered the start and end codes as @0scar suggested. CarlWitthoft, the Cura version I am using does not have a specific selection menu for the Anet A8. I believe I had to specify a custom printer when setting it up. What is your suggestion for the negative (x,y) spaces? - sorry about this, am new to all of this. $\endgroup$ – user18696 Oct 2 '19 at 19:58

do you set the {speed_print} value correct? Otherwise the command G1 Z15.0 F {speed_print} is not executable imho...

  • $\begingroup$ Good catch, +1, the variable/keyword is called {print_speed}! IMHO it is far better to use a fixed value rather than a a print speed to move the platform... $\endgroup$ – 0scar Oct 4 '19 at 15:16
  • $\begingroup$ Interesting - there appears to be no value following the code G1 F{speed_print} simply a blank line. I have added a second image showing the value for {speed_print} which in this case is blank. $\endgroup$ – user18696 Oct 5 '19 at 16:09
  • $\begingroup$ @user18696 That is because {speed_print} does not exist! It is called {print_speed}, but you shouldn't use that parameter at all, you should use a fixed value. $\endgroup$ – 0scar Oct 8 '19 at 5:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.