1
$\begingroup$

I've been running this Ender 3 Pro for quite some time with no problem up until recently. The issue was the printer refused to extrude filament (the extruder stepper seems to be rocking back and forth) so I went through a few things to try and fix the problem:

  • I leveled the bed properly
  • I printed at higher temperatures (215 °C for PLA which is the only filament I run in this printer)
  • I cleaned the nozzle and I actually replaced the nozzle with a new 0.4 mm nozzle (same size as before)
  • I replaced my bowden tube with a newer one (unbranded) and even replaced the tube fittings for the extruder assembly and the heat sink.

I saw somewhere that maybe the wiring to the extruder gear is frayed but I inspected the extruder side of the connector and everything looks fine. I would open up the box and everything but I want to see if anyone has a solution before opening up the circuit box.

$\endgroup$
  • $\begingroup$ The question title suggests it is trying to move, but jitters, correct? Be sure that the extrusion speed doesn't exceed the maximum speed, steppers rock back and forth if a too high of a speed is commanded. $\endgroup$ – 0scar Oct 30 '19 at 6:02
  • $\begingroup$ My extrusion speed is 60 mm/s which is pretty standard from everything that I've seen. This speed works fine on all my other Ender 3 Pro's so I don't think that is the issue but I will slow down the speed and test just in case. $\endgroup$ – Daniel Bozarth Oct 30 '19 at 16:49
  • 1
    $\begingroup$ No need to lower it, just establishing that it did not accidentally was too high of a speed! $\endgroup$ – 0scar Oct 30 '19 at 18:56
2
$\begingroup$

Sounds like one end or the other in your stepper cable is not seated correctly or has shaken loose there are 4 wires if even one doesn't make proper contact you will get a shaking back and forth almost like a hard vibration. I always take a cable from one of the other steppers plug into this one move the motor with good stepper wire 10-20 mm see what motor does if it is okay then you know it is a cable issue if not, it could be a bad board or stepper.

| improve this answer | |
$\endgroup$
  • $\begingroup$ ALright, I will try this out and let you know if the problem is with the cable or not. $\endgroup$ – Daniel Bozarth Oct 30 '19 at 16:47
  • $\begingroup$ The cable is indeed the problem as the motor moves filament through no problem so I will check the extruder cable. $\endgroup$ – Daniel Bozarth Oct 30 '19 at 16:56
  • $\begingroup$ I opened up the main control box and everything seemed fine. I took a multimeter and checked each connection, every cable is a solid connection so that wasn't it. I put everything back together and the extruder worked perfectly. Now I try printing today and the extruder motor doesn't move at all so I am completely boggled. $\endgroup$ – Daniel Bozarth Oct 31 '19 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.