2
$\begingroup$

I am using the Octoprint Bed Visualizer on my Ender 3/BLTouch setup. When it moves to the front left corner, the BLTouch sensor nearly misses the bed touching the very edge. Likewise, it is shifted fairly far forward in the back.

Is it possible to shift the Y axis only for the visualizer? I see there is an M206 gcode that apparently does this, but putting the code into the Visualizer settings doesn't seem to make a difference.

UPDATE: I checked the firmware settings and they are set as follows, which seem correct,

X_PROBE_OFFSET_FROM_EXTRUDER -41
Y_PROBE_OFFSET_FROM_EXTRUDER -5
X_BED_SIZE 235
Y_BED_SIZE 235
$\endgroup$
10
  • $\begingroup$ did you define the offset of the Z-probe to the nozzle position in the firmware? $\endgroup$
    – Trish
    Nov 3, 2019 at 1:05
  • $\begingroup$ Yes when I updated the firmware I believe I set it correctly but I’ll double check. Thanks for the reminder $\endgroup$
    – McArthey
    Nov 3, 2019 at 1:06
  • $\begingroup$ I found a good external link that I'm going to play with for a bit: github.com/JimBrown/MarlinTarantula/wiki/… $\endgroup$
    – McArthey
    Nov 3, 2019 at 2:34
  • $\begingroup$ Did you set the correct boundaries for the sensor in your firmware? You might want to read: "How to set Z-probe boundary limits in firmware when using automatic bed leveling?". $\endgroup$
    – 0scar
    Nov 3, 2019 at 7:31
  • 1
    $\begingroup$ Could you post your last comment as an answer, please..? If you answer in the comments then the Q&A mechanism of the site gets broken, and in addition, it doesn't decrease the length of our unanswered queue, which we need to keep to a minimum in order to graduate out of being a beta site. Many thanks. :-) $\endgroup$
    – Greenonline
    Nov 15, 2019 at 17:48

0

You must log in to answer this question.

Browse other questions tagged .