4
$\begingroup$

I have been experimenting with PETG on my CR-10 upgraded with an E3D all-metal hot end and Marlin firmware on the controller. I am printing with 0.8 mm nozzle at 250 °C and an 85 °C bed.

When I print in vase mode, the prints come out beautifully (and quickly with the 0.8 mm nozzle). However, with solid-body prints, I routinely get a thermal runaway fault at about the third layer (the fault references E1). Can anyone suggest how to solve this and why the thermal runaway protection only trips with solid-body prints?

For context, when I tried to print the same solid-body print in PLA (205 °C hot end and 50 °C bed) I did not get the thermal runaway fault.

$\endgroup$
  • $\begingroup$ Hi and welcome to 3DPrinting.SE! At what speed do you print the vase perimeter and what is the speed during the failure (e.g. is it failing during infill or wall printing)? $\endgroup$ – 0scar Nov 22 '19 at 13:06
  • $\begingroup$ what version of marlin? Self made? $\endgroup$ – Trish Nov 22 '19 at 13:14
  • $\begingroup$ Interesting question..I will run another print now to confirm, but I believe it is failing when printing infill. In vase mode Simplify3D prints at ~900 mm/min. In normal mode, the perimeter prints at the same speed and the infill at ~1800 mm/min. I have it set to print at 1800 mm/min with 100 % underspeed for infill and 50 % underspeed for the outline, so this makes sense. Perhaps the speed is too high? $\endgroup$ – Ryan Nov 22 '19 at 13:23
  • $\begingroup$ Probably your speed is too high, I've composed an answer for you. You can lower speed/temperature or fiddle with the TRP settings. $\endgroup$ – 0scar Nov 22 '19 at 13:25
  • $\begingroup$ you are on the maximum temp, try to use 2-5° less. prints speed need to be also lower. $\endgroup$ – Fernando Baltazar Nov 22 '19 at 20:57
4
$\begingroup$

Thermal runaway protection (see What is Thermal Runaway Protection?) is triggered when the scheduled voltage to the heater element does not result in a specified increase in temperature within a specified timeframe.

The exit of hot filament from the nozzle and the loss of heat of the heater block and the conduction heat loss through the heat break to the cold end need to be supplied by the heater element. When the filament melting temperature is high, heat losses are relatively high as well, this means that the software needs to compensate by scheduling the heater element more quickly/activated sooner (there is some heat capacity in the heater block) and longer. If it is unable to provide enough heat than is being used, the temperature cannot be maintained and the printer notices that scheduling power doesn't result in a temperature rise. This will trigger the thermal runaway protection in the firmware.

This can imply that too much heat leaves the nozzle in the form of hot filament, and as such, your printing speed may be too high (or the printing temperature too high).

Note that you are using a 0.8 mm nozzle diameter, this means a flow increase of $ \frac{0.8^2}{0.4^2}=4 $ with respect to a "standard" 0.4 mm nozzle! A slower print speed is therefore advised anyways.

To solve this, you can either:

  • Insulate the heater block, e.g. with a silicone sock
  • Install a different type of heat block, e.g. a E3D Volcano which has a larger heat input zone
  • Print slower
  • Print at a lower temperature
  • Change the firmware settings of your TRP (should be done with care!)

To explain the latter option, from the Configuration.h you can read that if you encounter these problems, you can tune this in the Configuration_adv.h

Excerpt from Configuration.h:

 * If you get "Thermal Runaway" or "Heating failed" errors the
 * details can be tuned in Configuration_adv.h

Excerpt from Configuration_adv.h:

 * If you get false positives for "Thermal Runaway", increase
 * THERMAL_PROTECTION_HYSTERESIS and/or THERMAL_PROTECTION_PERIOD

So you need to change these constants:

#define THERMAL_PROTECTION_PERIOD 40        // Seconds
#define THERMAL_PROTECTION_HYSTERESIS 4     // Degrees Celsius

The most effective solution for your problem will be limiting print speed and experiment with printing at slightly lower temperatures.

| improve this answer | |
$\endgroup$
  • 2
    $\begingroup$ Adding a silicone sock and slowing down was enough to stop the issue. Thank you for the education! $\endgroup$ – Ryan Nov 23 '19 at 22:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.