2
$\begingroup$

I have a TEVO Tarantula printer, recently I have upgraded it's firmware from the stock firmware to marlin 2.0 using this configuration repo.

Since upgrading my prints take 2x the time they used to (and the time Cura says they should take). I have tried to increase the printer's acceleration and jerk maximum configuration, but it did not help.

In addition, another symptom that is new is that whenever a straight line is printed (for example an infill line) instead of the motors moving in one swift motion, I can see (and better yet, hear) them moving in a different speed. Specifically, it looks like the motors slow down midway and start again.

How can I address those issues?

$\endgroup$
  • $\begingroup$ Also if your Marlin 2.0 is using junction deviation (new default) then jerk settings may be ignored. Default JD amount is equivalent to extremely low jerk. JD still seems to be buggy so I'd switch it off and go back to classic jerk. $\endgroup$ – R.. GitHub STOP HELPING ICE Mar 5 at 18:28
3
$\begingroup$

First, Ultimaker Cura estimated printing times are not necessarily accurate for non Ultimaker printers. For Ultimaker printers this is perfectly tuned, Cura estimates the printing times from experience for the UM3E correctly. Please look into question "How to determine real printing speed (tarantula/cura)?" which is relevant to this question and has an interesting accepted answer.

Second, changing the MAX accelerations will not work, you should increase the default acceleration:

From the TEVO Tarantula Marlin fork you read from the Configuration.h file:

/**
 * Default Acceleration (change/s) change = mm/s
 * Override with M204
 *
 *   M204 P    Acceleration
 *   M204 R    Retract Acceleration
 *   M204 T    Travel Acceleration
 */
#define DEFAULT_ACCELERATION          1000    // X, Y, Z and E acceleration for printing moves
#define DEFAULT_RETRACT_ACCELERATION  2000    // E acceleration for retracts
#define DEFAULT_TRAVEL_ACCELERATION   3000    // X, Y, Z acceleration for travel (non printing) moves

From the main Marlin source you will find:

/**
 * Default Acceleration (change/s) change = mm/s
 * Override with M204
 *
 *   M204 P    Acceleration
 *   M204 R    Retract Acceleration
 *   M204 T    Travel Acceleration
 */
#define DEFAULT_ACCELERATION          3000    // X, Y, Z and E acceleration for printing moves
#define DEFAULT_RETRACT_ACCELERATION  3000    // E acceleration for retracts
#define DEFAULT_TRAVEL_ACCELERATION   3000    // X, Y, Z acceleration for travel (non printing) moves

The TEVO Tarantula sources have lower default acceleration values, you could try to increase those.

| improve this answer | |
$\endgroup$
  • $\begingroup$ +1 - since EEPROM settings are enabled in this firmware, you'd probably want to M502 M500 to clear the previous settings out. $\endgroup$ – towe Dec 9 '19 at 15:17
  • 1
    $\begingroup$ @towe - You suggested a "+1" but never voted? I would hope you can fix that! :o) Voting is essential to the well being of this and every Stack. $\endgroup$ – Pᴀᴜʟsᴛᴇʀ2 Dec 9 '19 at 18:41
  • $\begingroup$ I'm sorry it took me so long to respond. I have implemented your suggestions, and also matched the Jerk settings to the original Marlin repo. My prints are now 'only' 50% slower than what Cura predicts. Do you have any more ideas about what can I adjust? $\endgroup$ – AlonMln Dec 31 '19 at 10:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.