4
$\begingroup$

After printing successfully for a while I received an error saying:

Tool 0 Failure!
Temp limit reached
Shutdown or restart.

The front panel is not responsive and doesn't allow the printer to print at all. If I quickly go to monitor mode it shows tool 0 temperature in the ~700°C range; which made me think it was the thermocouple.On the motherboard I unplugged the thermocouple and the same error occurred, I then swapped the other thermocouple and put it in its place and got the same error except the tool 1 temperature showed "NC".

I had recently taken apart the extruders to change out the nozzles and thought I had possibly smashed the wires when putting it together but now I don't think that's the case.

I'm on the phone with FlashForge's tech support but wanted to see if someone else has had the same experience for cross reference.

What's the underlying issue? Is there a quick solution to this that can get me printing right away (I'm under a deadline)? What's the end solution?

$\endgroup$
  • $\begingroup$ It's possible the sensor wire has been damaged. I've heard of sensors being damaged, resulting in the machine continually "increasing" the extruder temp, but usually it will timeout. $\endgroup$ – tbm0115 May 11 '16 at 23:30
2
$\begingroup$

It sounds like a failed TC amp chip. But we need to rule out some other stuff.

Some important facts about the Creator Pro temp sensor:

  • If you smash and short the two thermocouple wires together, the printer will simply read room temp.
  • If you cut or disconnect the thermocouple wires, the printer will report NC for "not connected."
  • The thermocouple lookup table in the firmware only goes up to 300C.

Seeing a number over 300C means either a bad thermocouple amp chip, or excess voltage on the TC wires due to a short to something else in the hot block. (However, such a short will usually fry the entire controller board to smithereens.)

To rule out stray voltage entering the TC wires, completely detach both thermocouples from the hot blocks and lay them out not touching anything metal. Do you still get an unusually high reading on tool 0?

To rule out an issue with the specific thermocouple, swap thermocouples between tool 0 and tool 1 and see if the problem moves with the TCs.

If the TC is not touching anything, and the problem stays with the tool when you swap wires, and you STILL get >300C reads, the thermocouple amp chip has failed. It is possible to replace the chip if you have (or your friend has) a hot air rework station and some experience soldering. Or you can get a new mainboard from FlashForge.

The next question is why this problem happened. You don't want to fix the symptoms with new parts but have an underlying issue cause the same failure to re-occur after you swap out parts. With the printer on but the heaters off, use a multimeter to check for voltage between the hot block and the printer's ground. Certain types of heater cartridge failure can short the hot block to +24v. This is highly dangerous and needs to be fixed before you continue using the printer. So make sure you check it before trying to repair anything else.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Still get the same error after removing both thermocouples completely and swapping. I noticed a lot of static when touching the chassis. Could be the root cause of the issue. $\endgroup$ – Cameron Stark May 12 '16 at 16:29
  • $\begingroup$ Yes, static could potentially fry the TC amp. $\endgroup$ – Ryan Carlyle May 12 '16 at 17:15
  • $\begingroup$ Is there an instruction set on how to check voltages around the device that you're aware of? $\endgroup$ – Cameron Stark May 12 '16 at 19:33
  • $\begingroup$ Hmm, not a manual or anything. I would flip the (powered up) printer over on its side, put one multimeter probe on a V- terminal on the PSU, and poke the hot block for tool 0 (right extruder) with the other multimeter probe. If it's 24 you have a bad cartridge. Make sure you're hitting aluminum and not insulation. Another thing you can check is whether the tip insulation on the TC itself is damaged... disconnect the TC completely and measure resistance from the tip to either of the wire terminations. Should be infinite / out of range. If it's low, you need a new TC. $\endgroup$ – Ryan Carlyle May 12 '16 at 21:23
  • $\begingroup$ Static is a big deal.. $\endgroup$ – StarWind0 Jun 16 '16 at 15:20
0
$\begingroup$

Oh yeah my printer had that. Specifically 2 Flash Forge Creator Pros, Replace the thermal couple. Done. Really fragile thermal couples they use.

Edit I see you tried shorting the TC. Wouldn't shorting the TC, produce the same error?

| improve this answer | |
$\endgroup$
  • $\begingroup$ To whomever is down voting, please post comments so we can improve the answers. $\endgroup$ – StarWind0 Mar 19 '18 at 22:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.