2
$\begingroup$

I was just informed via a comment that the TH3D Unified firmware a version of Marlin that's no longer updated and considered obsolete (1.9.X in this case) and that, since I'm flashing my firmware to fix my default e-step settings, I might as well flash a non-obsolete firmware.

However, something in the back of my mind is telling me that I can't use Marlin 2.0 because of some hardware limitation.

I'm using the Creality CR-10S printer (with the Creality 2.0 board, I believe) which is an 8-bit CPU. What should I look out for before upgrading to Marlin 2.0?

Marlin's Install website suggests that 8-bit AVR printers can use it (flashing via Arduino IDE). SO I guess I'm double checking before I do something that could potentially brick my printer.

$\endgroup$
  • $\begingroup$ @Trish I've edited my question to include that info. Thanks! $\endgroup$ – Lux Claridge Jan 15 at 17:02
  • $\begingroup$ Not sufficient for an answer, but I'd start by backing up the existing firmware in case you find that the new one doesn't work or has bugs/misfeatures you don't like. $\endgroup$ – R.. GitHub STOP HELPING ICE Jan 15 at 17:14
1
$\begingroup$

It wasn't advised to use the version 2.x because it was in development for 32-bit micro processors. Now that it has been released as the official version, you can use it for 8-bit micro processors.

But, it totally depends on the amount of options in Marlin you activate (bed leveling, advanced menu, M5xx, etc.). Luckily you can see how large the installation is after you have built it e.g. in PlatformIO. Also, in the configuration files frequently is mentioned how much extra storage activating an option costs (search for PROGMEM in the Marlin sources). Unless you want all options active, you'll be fine. I'm running it on an AVR (MEGA2560) for a CoreXY with bed leveling and some more options; it runs fine.

| improve this answer | |
$\endgroup$
  • $\begingroup$ It always worked well for 8-bit controllers too. I found that, using the example config files for the same printer, Marlin 2.0 also compiles to about 7% less space - but that was just one data point. $\endgroup$ – towe Jan 16 at 7:34
  • $\begingroup$ @towe Yes it always worked, but it was not advised as it was a development version! :-) $\endgroup$ – 0scar Jan 16 at 7:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.