0
$\begingroup$

Stepper motors are not working when connected to RAMPS board in the X,Y,Z pins.

I used A4988 drivers and the Arduino board is an original version. I checked the input voltage to the RAMPS board, it's 12 V. The bed and the stepper motors are working fine. I tried replacing the driver, checking with another RAMPS board, replacing the SMPS nothing has worked. I checked the input voltage of the arduino both the 5 V and 3.3 V pins are working fine.

$\endgroup$
  • 1
    $\begingroup$ VM (12 / 24V) is present on the driver? VCC (3.3 / 5V) is present? Enable is LOW, and you're supplying signals to STEP? $\endgroup$ – towe Jan 21 at 7:11
  • $\begingroup$ I'd like to know what PSU power wattage you are using. It needs to be at least 240W (12V x 20amps). Make sure to match the PSU and the board. Do not use 24V PSU with 12v board without 12v mosfet. $\endgroup$ – D DD Jan 31 at 4:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.