0
$\begingroup$

I want to use my secondary Win 10 PC for Octoprint (Direct connection to the Printer via USB) but Windows detects the Printer as "Unknown USB Device (Device Descriptor Request Failed)" Im 99.9% sure the cable is not the problem cause it works perfectly fine on any other device. Ive tried installing multiple Driver versions (including the one that came with the printer) but no luck yet. I also tried different cables/USB ports, no luck either.

https://imgur.com/a/H6IKAXM (Device Manager)

https://imgur.com/a/tqwqDMO (Properties)

From Properties->Events->Information I get this:

Device USB\VID_0000&PID_0002\6&23938f4b&0&4 was configured.

Driver Name: usb.inf
Class Guid: {36fc9e60-c465-11cf-8056-444553540000}
Driver Date: 06/21/2006
Driver Version: 10.0.18362.1
Driver Provider: Microsoft
Driver Section: BADDEVICE.Dev.NT
Driver Rank: 0xFF0000
Matching Device Id: USB\DEVICE_DESCRIPTOR_FAILURE
Outranked Drivers: usb.inf:USB\DEVICE_DESCRIPTOR_FAILURE:00FF2000
Device Updated: false
Parent Device: USB\VID_8087&PID_0024\5&2564d19a&0&1
$\endgroup$
  • $\begingroup$ Did you install the driver? This looks as if the CH340/1 driver is not installed. $\endgroup$ – 0scar Sep 28 at 6:16
0
$\begingroup$

I use linux, so I am not familiar with Win10 stuff. But, it seems that the device driver has asked the USB device for its identifying codes (PID and VID) and got no recognisable response. Could be a bad cable, but you seem to have checked that. Could be a fried USB interface chip, so check whether you have any luck trying to connect to any other computer. If you can find someone with a linux machine (or you have something you can run linux on), the logs will tell you a lot more about what has been tried and what failed (or not).

Note that the parent USB device is VID=8087 (being Intel Corp.) and PID=0024 (being the Integrated Rate Matching Hub) - see https://devicehunt.com/search/type/usb/vendor/8087/device/0024.

| improve this answer | |
$\endgroup$
  • $\begingroup$ So apparently Windows is the problem. My printer is recognized as "ttyUSB0" on Ubuntu 18.04. From now I will only talk about Ubuntu. Now the problem is that I cant connect to the serial port. Every time I try to connect i only get sth like "Permission denied - Line in use". Same results with Root user or sudo $\endgroup$ – Daniel2193 Feb 2 at 16:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.