I'm trying to troubleshoot an issue with my 3D printer (Robo 3D R1+). It cannot print vertical walls well any more. Here is a picture of what it looks like:

enter image description here

The walls are very inconsistent. To correct this issue, I've tried:

  • Changing the nozzle
  • Tightening the hotend (to remove wobble)
  • Dehydrating the filament
  • Using brand new (good quality) filament
  • Printing faster & slower
  • Printing hotter & cooler
  • Trying different slicers (Ultimaker Cura & Simplify3D)
  • Putting on a belt tightener

The 5 motor drivers are all new as well, but this was already happening before I changed them.

  • $\begingroup$ Check for play/loose nuts of the X-Z carriage/assembly. $\endgroup$
    – 0scar
    Commented Feb 1, 2020 at 6:47
  • 1
    $\begingroup$ Could be inconsistent Z movement. Get calipers, measure how much the Z moves when directed to move 100 mm. Let us know. $\endgroup$
    – Davo
    Commented Feb 1, 2020 at 14:32
  • $\begingroup$ What layer size are you printing? $\endgroup$
    – 0scar
    Commented Feb 6, 2020 at 21:07
  • $\begingroup$ Isn't it Z wobble? Do you have the same effect on different parts? ( I mean, check if the same fatten/tighten patterns appear on the same height on different models). $\endgroup$
    – smajli
    Commented Feb 7, 2020 at 22:11

3 Answers 3


Mmm... you've tried lots of obvious things. I don't have a printer the same as yours, so my help is generic.

How about a thorough check of extruder and filament path, since it may be just inconsistent filament feed? I've seen something similar happen when the filament reel was not rolling freely. Less likely, but also check that the frame is still solid and nothing has come loose.


Despite the picture being a bit small and blurry, it is quite obvious that something is off. A better picture might help closing in on the problem with more precision.

From what I can see it could be wrong extrusion settings. I'm making a wild guess based on personal experience that the printer is over extruding way too much. I had similar looking parts a few years back after a firmware update. I simply forgot to update the steps/mm for the extruder.

Any recent firmware or hardware updates? From your explanation I understand you changed the drivers. Maybe an issue based on microstepping? (The corner looks like the nozzle was realy in the material while printing.)


It looks to me like you might be over-extruding. Have you calibrated the extruder?

How-To: MatterHackers Extruder Calibration Video

More Info: all3Dp Over-Extrusion Page


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .