2
$\begingroup$

Prusa, I3 Mk2.
Marlin 2.0.3

The test model printed fine prior to installing Marlin 2.0.3. It's not the slicer or GCode. I tried several models, and all of them worked perfectly prior to the update. The video below shows what's happening. The Z axis homes, then when the heating is over the head centers, and rises to 15 mm (as shown on the display). The print starts, the head doesn't move down but the display shows 0.1 mm. I know I missed something in the Configuration.h but I can't figure out what.

$\endgroup$
8
  • 1
    $\begingroup$ This sounds like the G-code contains a bad command. Might you share the first about 50-100 lines of G-code? We can cut it back then. If it is too long, pastebin is a good choice for the whole thing. Another possibility might be wrong Steps/mm on the Z-axis $\endgroup$ – Trish Feb 14 '20 at 14:59
  • $\begingroup$ So the code worked just fine previously. This only happened after the firmware update. The model was never re-sliced. pastebin.com/V7QSS83M The only thing different about the firmware config was the enabling of Mesh bed leveling. I assume that's the issue but I have no clue. $\endgroup$ – Jared Feb 14 '20 at 17:32
  • $\begingroup$ ok, I see no misplaced Z-movement commands, this must be in the firmware. Now, we would need that... $\endgroup$ – Trish Feb 14 '20 at 17:38
  • $\begingroup$ Could the firmware have a misconfigured Z axis offset (stale data in EEPROM?) or similar? $\endgroup$ – R.. GitHub STOP HELPING ICE Feb 14 '20 at 18:03
  • $\begingroup$ Welcome to 3DPrinting.SE! Please post a link to your configuration.h, e.g. posted on PasteBin so we can help you. Also post the brand, this isn't an original Prusa, or is it? $\endgroup$ – 0scar Feb 14 '20 at 19:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.