1
$\begingroup$

I've created a model in Sketchup and exported the file as a .stl Since the model is 80cm x 24 cm i need to cut it in meshmixer. But when i open it in meshmixer it appears tiny. Why doesn't it open as the real size?

$\endgroup$
  • $\begingroup$ it might automagically scale to the size of the chosen printbed, or it might be that the model actually is such tiny. It would help to have access to the model. $\endgroup$ – Trish Feb 21 at 8:29
  • $\begingroup$ Perhaps you modeled it in cm, but most programs import in mm. The stl file does not include a scale, just a number of units. $\endgroup$ – Davo Feb 21 at 19:34
2
$\begingroup$

You mention your dimensions in cm. Any chance that the STL export is also in cm where Meshmixer might expect mm?

Assuming your Sketchup template was set to cm:
To validate this guess you could measure/eyeball a known dimension and if that comes out to be 10 times too small you could scale your model by 10 times. Alternatively you could adjust the template in Sketchup.

Additional information on STL files: By it's very nature, the STL file format is just a bunch of unitless numbers in a well defined structure. This structure represents a set of points (vertices), lines (edges) and and triangular surfaces (facet). A few simple rules apply to exactly how all this should be defined. (See here)

But the key thing here is that an STL file is not aware of units, the program used to generate the STL file (e.g. CAD software) needs to be told what units to use, and accordingly the reading program (e.g. slicer) needs to use the same settings. Generally in mechanics applications we default to mm, at least in metric land. All this is explained a bit more verbose here.

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Genius!! It worked perfect when changing to milimeters. But now the model appears outside and far away from box printer box (yes i am new to this) $\endgroup$ – Tobbe Feb 21 at 8:48
  • $\begingroup$ Any chance you made your drawing offset from the world zero? As in: where did you draw you part in Sketchup, at the origin or just somewhere else? (Although you can change that in Meshmixer as well by using the align tool.) $\endgroup$ – dex Feb 21 at 8:53
  • $\begingroup$ The align worked. But the printerbed is not centered to the screen. It uses the center of the model (original zero) so it becomes weird when I rotate the model $\endgroup$ – Tobbe Feb 21 at 8:58
  • $\begingroup$ At this point I am a bit unclear on the specifics. What exacty do you need to accomplish in which software? I understand you design with Sketchup, and want to cut it up in Meshmixer. What slicer are you using. (Some slicer allow you to do the cutting part in the slicer as well.) $\endgroup$ – dex Feb 21 at 9:17
  • 1
    $\begingroup$ Can you split the model in subparts and import those into Cura? From there Cura should put the pieces in the center and on the buildplate. $\endgroup$ – dex Feb 21 at 9:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.