Hello guys I have a little problem with printing. Whenever I print something there are always these lines my printer does, it's not a very big deal, but it looks rather ugly and I'd really appreciate it if anyone could help me if you know what the problem is. I post also a picture to show you the problem clearer. From what I see (observing how my printer prints), I noticed that it starts printing at one point and then when it arrives again after a circle to the starting point to print the layer above, it stops just a millisecond (instead of keep moving smoothly) and I think that's how the problem is created. I'm pretty sure its not the printer's problem, but probably the G-code or the filament... I don't know for sure.

Here some details:

  • Printer: Creality Ender 3 Pro
  • Slicer: Cura
  • Filament: PM filament, PLA, 1 kg, 1.75 mm

seam in print object

  • 2
    $\begingroup$ That's a pretty common (and unfortunately somewhat normal) problem - called "Z seam" $\endgroup$
    – towe
    Feb 28, 2020 at 12:32
  • 1
    $\begingroup$ Have you seen any improvement when using "random" for layer change positioning? $\endgroup$
    – Davo
    Feb 28, 2020 at 13:36
  • $\begingroup$ @Davo: In my experience, "random" just makes warts all over the place rather than all in one place where you could sand them off. $\endgroup$ Feb 28, 2020 at 14:27
  • $\begingroup$ @R..GitHubSTOPHELPINGICE then I suggest your advance/retract settings are not high enough. $\endgroup$
    – Davo
    Mar 2, 2020 at 12:25
  • 1
    $\begingroup$ @Davo: I mean without fixing the fundamental cause of the warts. If you get rid of them and there's only a very subtle seam left then yes random might look better. $\endgroup$ Mar 2, 2020 at 14:48

1 Answer 1


As towe noted in a comment, that's Z seam. The mechanism by which it happens is mostly the same as bulging corners. The print head is moving considerably slower just before and just after the layer change, decelerating to a stop then accelerating back up to speed in order to perform the slow Z-axis move, but the rate of extrusion, which is dependent on pressure built up (in the compression of the filament, and possibly expansion of the bowden tube) between the extruder gear and the nozzle, not directly on the motion of the extruder gear, remains the same.

In my opinion, the best fix for this is upgrading to firmware that compensates for it. In Marlin firmware (the stock Ender 3 firmware is based on Marlin 1.0), this feature is called Linear Advance. You tune a spring constant for your material's compression, and after setting it, extrusion is roughly proportional (linear) with respect to logical E-axis moves, regardless of the speed the print head is moving. However, upgrading firmware is nontrivial to do, and has a lot you might have to tune/tweak to get it working the way you want.

Short of that, there are a lot of ways of mitigating the problem:

  1. Select "Outer Before Inner Walls" option (in Cura, or equivalent in other slicers) and "Infill Before Walls" when slicing. This will ensure the layer change happens inside the model (on an inner wall) not on the outside surface, because outer surface is neither the first nor last thing printed on the layer.

  2. Increase X/Y acceleration and/or jerk limits so that motion can start/stop a lot quicker, so there's a shorter period for the disproportionate extrusion to happen in. But if you do this too much, you'll get layer shifts (failed prints) or at least bad vibrations that show up in print surface. My Ender 3 can handle accelerations up to at least 3000 mm/s² in X and Y and 10 mm/s "jerk" (a misnomer, thus the weird unit) and you can likely go higher if you experiment.

  3. Tell slicer to retract at layer change. This will prevent extrusion from continuing during the Z move, but won't help with the extrusion during the time you're decelerating/accelerating in the XY plane.

  4. Increase Z acceleration/jerk. This will reduce the time spent during the Z move, and might even allow the head to keep moving without coming to a full stop during layer change (but that can't happen if you turned on retract at layer change).

  5. Print at lower speed. If the max speed is lower, it takes less time to decelerate/accelerate from/to it, and nozzle pressure will be lower (so extrusion is naturally closer to linear).

  6. Enable coasting in your slicer. This is a hack that really poorly approximates what Linear Advance would do, but it can lead to underextruded walls and brittle prints. I always had bad luck with it and don't recommend it, but it's an option.

I would recommend starting with items 1 and 2. #1 is good for a lot of other things too, and the only tradeoff is that overhangs might print worse (in my experience that's not really the case and they sometimes print better even). And #2 will get you faster prints (sometimes at lot faster) which is nice.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .