2
$\begingroup$

I have a previously working Anet A8 that I just flashed to Marlin 1.1.9 (bugfix) and installed a real BLtouch sensor. I followed setup instructions and believe my wiring is correct. When I try to do a G28, the extruder moves to the front left corner properly, then moved to center the BLtouch over the bed. Then, it moves up instead of down, the BLtouch drops the probe, the extruder moves up again, the BLtouch drops the probe again and the extruder moves up again until the carriage is near the top. Using Pronterface I can move the carriage back down, but have to use M211 S0 to let me get it close to the table. X, Y and Z move properly in Pronterface. I have changed the relevant settings in Marlin and recompiled with no success. The BLtouch does it's self test correctly and I can control the probe with commands.

$\endgroup$
5
  • $\begingroup$ Hi, welcome to 3DPrinting.SE! Could it be that Z_MIN_PROBE_ENDSTOP_INVERTING has an incorrect value? It should be false. $\endgroup$ – 0scar Mar 3 '20 at 13:26
  • $\begingroup$ I tried changing that with no effect. One setting I would like to try but can't is #define Z_HOME_DIR -1 changed to 1. Marlin won't compile and gives lots of errors that I haven't been able to resolve. $\endgroup$ – Tim Shoemaker Mar 3 '20 at 18:43
  • $\begingroup$ Z_HOME_DIR should be -1. Please add the instructions you followed, the BLTouch is a little more difficult to wire to the Anet board (using a pin from the LCD cable). For that reason I used an inductive sensor on my Anet A8. $\endgroup$ – 0scar Mar 4 '20 at 7:06
  • $\begingroup$ I replugged the z stop microswitch and disabled the BLtouch features and bed leveling in Marlin 1.1.9bf. The A8 functions perfectly with the manual z switch. I am able to print just fine. I then plugged in the BLtouch in place of the z stop microswitch, enabled the BLtouch features per the youtube youtube.com/… The result is the same as before, with a G28 command, the nozzle homes to the center of the bed, but the carriage goes up instead of down. The BLtouch cycles the pin twice and the carriage moves up. $\endgroup$ – Tim Shoemaker Mar 5 '20 at 13:59
  • $\begingroup$ Somehow in the homing sequence, the z servo is getting the wrong command. The z works correctly with Pronterface or when I use the mechanical z stop and disable BLtouch. It's got to be a setting or code issue with the BLtouch homing sequence. $\endgroup$ – Tim Shoemaker Mar 5 '20 at 14:05
2
$\begingroup$

SOLVED -- The problem turned out to be that the BLtouch was set up for 3.3 V and my Anet board is 5 V. The docs were not clear on what the BL defaulted to and I mistakenly thought 5 V. After I did a M280 P0 S140 command, the carriage would home properly with G28. Why it was going up instead of down was a Red Herring. I changed the settings in configuration_adv.h to force 5 V and did the EEPROM one time write. Now the A8 works correctly. Thank you for your help Oscar.

$\endgroup$
1
  • $\begingroup$ You're welcome, please accept after 48 hours! $\endgroup$ – 0scar Mar 8 '20 at 8:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.