I've got a peculiar issue today, and was looking for some help with it.

Of the six Ender 3s I manage at my college, one of them seems to be stretching the Y axis of all the prints I make with it.

Some points about the issue:

  • It's variable, but is much more pronounced in larger prints:
    • A raspberry pi frame-mounted case I printed came out too long along the Y-Axis by over 2 mm.
    • To troubleshoot, I printed a calibration cube but the Y-axis was only 0.5 mm longer.
    • It seems to affect only part of some prints; a bit over half of the pi case was stretched, but a section at the top appeared normal (screw holes were perfect circles, but towards the other end they were ellipse-shaped).
  • I tried tensioning the Y-belt, and while I noticed it was loose before tightening it, this didn't make a noticeable improvement.
  • It doesn't occur in any of the other five Ender 3s, all of which are equal in modifications.
  • A re-flash of the Marlin firmware didn't fix the issue. It's a preconfigured Marlin version that I pulled off github based on a recommendation. I flashed this version to try and solve the problem, the previous version was installed by the printers' previous caretaker but the new version didn't help (makes me think we might have both grabbed the same version).
  • It means that I can no longer print any components that require high tolerances, as they simply won't fit together.

The most recent print was a 40 mm fan shroud for a "hero me" setup (which I'm working on installing on all six printers).

  • I ran two of them, one on the printer with the issue and one on a perfectly functional printer.
  • They were run this morning, in identical conditions and started at the same time.
  • There are no other structural defects aside from the stretching, it simply looks like a normal, print but as if someone used the photoshop transform tool and pulled it.

Here is a side by side of the two finished prints, comparing them along both the X and Y axes. As you can see, the X axis is perfect on the problem print, but the Y is consistently stretched (visible in the shape of the round cone and the screwholes).

enter image description here

This issue has been consistent and I'm honestly stumped, any help is appreciated! If anyone needs me to obtain more documentation or test something, I'll be back in with the printers in the morning (roughly when this post is 10 hours old) and I'm happy to get any documentation needed.

  • 2
    $\begingroup$ @Finn, check that the set screw on the tooted pulley on the stepper motor hasn't come loose. (I've had that problem on a different machine) $\endgroup$
    – user77232
    Commented Mar 19, 2020 at 18:38
  • $\begingroup$ So, what I've now done is extruded two dots, and moved the y axis 70 mm between them (according to Marlin). Using calipers, the actual distance between them is 72.55 mm (pretty out of whack), so I used this formula to find a new steps/mm value for Y: 77.18. I re-ran the test and got a slightly too short distance, so I've re-done it one more time and left another one of the original prints. Problem solved! $\endgroup$
    – Finn
    Commented Mar 19, 2020 at 23:44
  • $\begingroup$ You should not change that Y value if it read the same as for the X! You have a hardware issue! $\endgroup$
    – 0scar
    Commented Mar 20, 2020 at 6:24
  • $\begingroup$ @0scar Changing it down slightly resolved the issue entirely, what other solution would there be? $\endgroup$
    – Finn
    Commented Mar 20, 2020 at 6:36
  • $\begingroup$ You probably need to replace the belts and ensure in the future to not over-tighten them. $\endgroup$
    – 0scar
    Commented Mar 20, 2020 at 8:25

2 Answers 2


If an axis doesn't print the sizes you command it there are basically 2 options causing this.

  1. The printer is incorrectly configured,
  2. The printer has an hardware issue.

To find out which of the 2 is applicable, you need to look into your setup and into the firmware settings. E.g. from the printers display you can read the amount of steps the stepper needs to make to move the axis 1 mm. Alternatively, send M92 through a terminal and look at the steps per mm. If X and Y are the same, the firmware is correctly configured and you are facing a hardware issue. Note that for the stock Ender 3 the value for X and Y needs to be 80 steps/mm. Do not alter these values!!! These values are based on the mechanical layout and the micro-stepping used by the stepper drivers.

Since you have flashed a stock hex firmware file it is highly improbable that the firmware contains the incorrect steps per mm value for the Y axis (unless you accidentally changed this through the interface/display). This leaves you with a hardware issue. Common reasons that could identify the source of the problem are:

  • Loose grub screw of the pulley on the stepper,
  • Missing steps, e.g. due to too much friction (if dimensions are smaller, in your case this is not the problem, it is added for completeness),
  • Loose, under tensioned belts,
  • Stretched belts as a result of over tensioning the belts.

Considering the stretched Y dimensions, the most logical explanation would be that your belts are stretched, you cannot fix this by changing the steps/mm value, it requires mechanical attention; i.e. replacing for new belts.


It is likely you have PU belt and it is likely it stretched in some area. I had all my PU belts finally stretched with big tension and high speed printing. Now I am using reinforced rubber belts.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .