I'm running Repetier Host v1.6.1 with Repetier Firmware v0.92.9. My computer is running Windows 7 Pro SP1, 64-bit.

If I set a print going via USB then switch to another user (note: I do not log out), then the pinter's display shows that the command buffer drops from 16 to 0 until it stops printing altogether. If I switch back to the user that is running Repetier Host then the buffer fills up again and the print job resumes.

Before I updated Repetier Host this didn't happen, I could leave it running while I switched users and the job would run just fine. I'm not sure why this behaviour has changed, but is there any way to get it to run properly under a background user?

  • $\begingroup$ Now, obviously there are workarounds, like putting the job on an SD card or just not switching users. Those are not solutions, they are workarounds, so please don't suggest them. $\endgroup$ – Excrubulent May 25 '16 at 2:43
  • $\begingroup$ Maybe your windows settings were changed. What about switching user with/witout logging off? windows.microsoft.com/en-us/windows/… $\endgroup$ – darth pixel May 25 '16 at 10:09
  • $\begingroup$ Yes, I am switching users without logging off. If I log off, Repetier Host will close and then the print job would be irretrievably lost. $\endgroup$ – Excrubulent May 25 '16 at 11:45

Is it possible that in updating Repetier you inadvertently installed it for a single user rather than for everyone? If so, that might account for its stopping when the user is changed.


I believe what happens here is that Windows suspends the process running the print job, either due to the program not being in focus, because you switch user, or both.

You could try to increase the priority of the print process in task manager, and see if that helps.

In Windows 7:

  1. Open Task Manager
  2. In the Applications tab, right click the application, and select Go To Process, which will take you to its background process in the Process tab.
  3. Right click the process, go to Set Priority and select some priority higher than the current level.

In Windows 10:

  1. Open Task Manager
  2. In the Processes tab, right click the application, and select Go To Details, which will take you to its background process in the Details tab.
  3. Right click the process, go to Set Priority and select some priority higher than the current level.

PS: Avoid setting the priority to Realtime, as that effectively will give the process full control of your computer's resources, which could kneel your computer if the program is poorly written.

  • $\begingroup$ I doubt this is a priority issue. It's rather set application in suspend/slip mode. Switching user (with logout) doesn't consider priority AFAIK. $\endgroup$ – darth pixel May 25 '16 at 10:18
  • 2
    $\begingroup$ Just tried it and changing the process priority has no effect. I didn't try realtime, but it doesn't look like it would matter. The issue occurs the moment I drop out to the user selection screen, and there are no other programs taking up system resources when I do that. $\endgroup$ – Excrubulent May 25 '16 at 11:54
  • $\begingroup$ If it stops the moment you change user, then priority probably doesn't matter at all. Turning off suspend-mode for the print process might work, as @darthpixel mentions. However, when you say that you change user, do you actually log out the first user, or are you only switching user? I am asking because there seems to be a difference. $\endgroup$ – Tormod Haugene May 25 '16 at 12:09
  • $\begingroup$ No, I do not log out, I switch user. What do you mean by turning off suspend-mode though? $\endgroup$ – Excrubulent May 25 '16 at 23:02
  • 1
    $\begingroup$ That is a good question. I found this post, which could be worth trying. It seems like a developer feature where /enableDebug turns off the standard lifecycle handling for the app in Windows, while /disableDebug enables it again. I understand that such a solution might not be for everyone, though! :) $\endgroup$ – Tormod Haugene May 26 '16 at 7:13

Maybe you've changed your power settings and that's why your USB port stops working when switching user (for power conservation). I know you've said it was working before Reptier update but maybe it's worth to check.

  1. So go to Start > Control Panel > Power Options

Find your (selected) power plan and choose Change plan settings > Change advanced power settings

Then check USB Settings > USB selective suspend settings

to be sure - set both to Disable

  1. Another place to check is My Computer > Manage > Device Manager > Universal Serial Bus controllers

And here there are at least 2 items to check

  • Generic USB Hub
  • USB Root Hub

both have tab Power Management and checkbox Allow computer to turn off this device to save power - uncheck them

I know it doesn't sound very wise but who knows... :)

  • $\begingroup$ Alas, changing the USB Selective Suspend settings made no difference, in fact they were already enabled, but I tried disabling just to be sure. Also, the USB hubs already had the "allow to turn off" setting disabled. I did learn something about the USB hubs though, the fact that they actually name what's attached to them and the devices' power draw is a useful feature that I'd never explored. $\endgroup$ – Excrubulent May 30 '16 at 0:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.