0
$\begingroup$

I built a 3D printer from scratch originally using a RAMPS 1.4 shield with Arduino Mega as a controller. About a week into the printer being finished and working well I installed a heated bed. It worked well at first, but after about a week one of the MOSFETs got really hot and started to smoke while the bed was heating up. After that I decided to get a new RAMPS 1.4 shield, and the same thing happened. After doing some research online, I found out that the MOSFETS on the RAMPS 1.4 typically under perform, and there are upgrades that handle the power much better. I decided to buy a RAMPS 1.6, as I had found it was rated to handle the extra current. The 1.6 worked really well for about a week, until earlier today while the bed was heating up for another print, the power connector began to smoke and caught fire very quickly. (Luckily I was aware of problems like that and watching it and was quickly able to unplug it). Note that this was a problem with the power connector and not the MOSFETs like the 1.4 board. To try and troubleshoot the problem, I plugged to power in and only the power (no USB connection) and immediately the power connection began to smoke again. So at this point I don't know how to approach this problem. I don't know what is causing it. Should I buy a new board? (I don't want to go with RAMPS again) or is there a way to fix the power connection?

| improve this question | | | | |
$\endgroup$
  • $\begingroup$ What heated bed and size are you using and at what voltage? It appears the connectors are not rated for the current. Apparently, the MOSFETs are not an issue any more with the 1.6, but you can always order external MOSFET modules to take the load of the board, but that doesn't seem to be an issue now. $\endgroup$ – 0scar Mar 27 at 17:08
  • $\begingroup$ The link to the specific heated bed I bought is here amazon.com/Anet-Aluminum-Upgrade-Printer-220x220mm/dp/…, -- But in short it's 220mmX220mm and it takes 12V. $\endgroup$ – Jack Hasselbring Mar 28 at 23:08
  • $\begingroup$ That particular bed is prone to catch fire, the connector is underrated for the current it needs to be replaced immediately. I have the same bed on my old Anet A8; I soldered the power cables directly to the pins. Your question is basically answered in "Anet A8 Hotbed Not Heating Correctly". $\endgroup$ – 0scar Mar 29 at 4:42
  • $\begingroup$ Possible duplicate of "Anet A8 Hotbed Not Heating Correctly? $\endgroup$ – 0scar Mar 29 at 4:47
  • $\begingroup$ Okay, so could a problem with an underrated heat-bed connector cause the fire/smoke on the RAMPS 1.6 shield? After inspecting the connector on the heated bed it looks to be completely fine other than one solder connection with a small black spot. And when you say the connector needs to be replaced do you mean the one on the RAMPS or heated bed? $\endgroup$ – Jack Hasselbring Mar 29 at 20:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.