1
$\begingroup$

I fired up my printer again last night to print something (Printrbot LC that I have customized), and happened to notice the Octopi instance still had a file that I printed ~5 years ago. Also, I noticed i had files from ~2013 when I got started. My printer is from that time, so keep that in mind.

I've noticed that sometimes I will see a Y axis shift, and then the print will correct itself. It did it again last night. Since this had happened before, I thought maybe the wires for the heated beds were getting snagged on something, so I made sure they were out of the way, and made sure they had proper strain relief before printing this thing.

However, about 1 cm up the Z axis, my print had a 1-2 mm shift of the Y axis for ~2-3 mm, and then corrected* itself somehow.

The Question

What is this kind of problem called? What should I look for to try to troubleshoot it? Let's make sure to include the possibility that one of my upgrades has gone awry to leave no stone unturned.

Stay on Target

My printer probably also has other problems, and that's fine to point them out after addressing my primary concern.

*Almost completely corrected itself. Maybe .5-1 mm off.

This is the print.

It'll be serviceable after some filing. It's from this thing.

enter image description here

enter image description here

enter image description here

This is my printer

enter image description here

Upgrades

  • Printrbot LC, I want to say I bought in 2010. It was a kit and I assembled it.
  • This pic is from 2014 and it's about the same.
  • I've extended the physical Z height, but supposedly the firmware needs to be updated to make use of it. I would still need to adjust the wiring too.
  • I've extended the Y axis (front to back).
  • As part of extending the Y axis, I added a 2nd heated bed. It's not plugged in, and I only use the one which is the one closest to the camera. There is room for a 3rd bed, but that was an accidental bit of engineering.
  • There was a lot of bow in the bed, even with the added support. I manually adapted this thing to add in a bearing to support the bed near where the hotend was. Manually with a dremel, super glue, etc.
  • I have noticed a clicking where the support bearing touches a screw holding the aluminum rail to the wood, but that would only impact prints for the second bed. The print I am asking about was in the middle of the primary bed, and far away from this.
  • I updated the belt and pulley to the G2(?) belts. Those are standard now, but this was an upgrade for this bot.
  • I added an additional support bearing for the hotends, which reduced the X axis slightly.
  • Added fans for the part and the incoming filament.

Misc

  • Bed is manually leveled by adjusting screws and nuts
  • Glass is held to the bed by small aligator clips
  • I print on bare glass with purple glue
  • I am using PLA+, hotend at 220 °C, and bed at 60 °C
  • I have an old version of OctoPi on a Raspberry Pi 1 controlling the printer
  • I sliced last night with Cura 4.1.0
  • I use 3 mm filament
  • Printer has a .4 or .5 mm hotend, whatever was stock (I don't recall, and I don't see the setting in Cura)
  • Printing at .2 mm height
  • I have noticed some wear on the 3D printed gears for the extruder, but they still seem to be working. I've been meaning to print some spares, and have printed a spare bigger one in case they fail.
  • The printer has wooden 1x4 supports in one corner, so none of the PVC cage moves at all now. It didn't move much before unless I was pushing on it.
  • I printed and screwed in some stops that go around the feet of the printer to prevent it from moving around.
  • The printer is very rigid with the above feet stops, the wooden supports, and the ~20lb roll of filament on top of the Z axis.
  • The y axis has some friction and some spots are tighter than others, so I will keep looking at the mechanics of the bed to see what I can do.

Things I have tried so far

  • Tried multiple things at a time, because screw science lol. Close to order of operations below, but not perfect.
  • Upgraded Cura to 4.5.0
  • Printed multiple times. Still have the problem.
  • Rotated print by 180 degrees. Same problem in same direction, at same height. Towards the Y axis zero.
  • Adjusted flow to 97%, so now I'm not overextruding. The screw holes come out as screw holes, and the top surface looks mostly normal. Once I'm done with this print, I might try 95%.
  • Cut a zip tie that may have been catching on bed clips.
  • Added more clips to hold the glass to the bed. Removed old clips that were worn out and may have been impacting the gantry.
  • Adjusted the tension on the screw that holds the bed and the guide rods, to reduce friction of the guide rods and their bearings. This reduced friction, but did not have an effect on the print.
  • Rotated print by 90 degrees. Same problem in same direction, at same height.
  • Watched the printer as it was printing the strange part. There were no mechanical collisions, and things seemed normal.

More thoughts

  • I will look into spinning up a new Octoprint server on a newer Raspberry Pi to see if that helps.
  • I am having a hard time finding examples of layer shift that didn't 100% kill the print. The fact that this corrects itself makes me think it's not the usual mechanical problems associated with layer shift.
  • I have added the other thing to the print (from the same designer and thing page), and we'll see if they both have the problem, or what else might happen.

Updated pics

enter image description here enter image description here enter image description here enter image description here

$\endgroup$
  • 1
    $\begingroup$ I would call it layer shifting, but that doesn't recover by itself! Is the frame rigid being made from PVC tubes? A big mass on top of a non-rigid frame does sound like a recipe for disaster. It looks as if the mass of the Y-axis is very large also. $\endgroup$ – 0scar Mar 29 at 22:26
  • $\begingroup$ I reprinted from the same GCode and got the same layer shift in the same spot, so I'm going to try to slice it in the newest version of Cura and print it and see what happens. $\endgroup$ – YetAnotherRandomUser Mar 29 at 23:26
  • 1
    $\begingroup$ My own printrbot does the same thing. Less extreme, but I too had layer shifts that persist across printing and slicing attempts. I am beginning to suspect that it's something to do with the acceleration of some part of that layer. I'd be interested to hear about how this gets solved. $\endgroup$ – RDragonrydr Mar 30 at 20:49
  • $\begingroup$ This is some really atrociously bad print quality in nearly all regards. Whatever's wrong with the machine can probably be fixed, but I suspect it will take a lot of work to get it working even close to as well as a $100 printer you can get nowadays. $\endgroup$ – R.. GitHub STOP HELPING ICE Mar 31 at 3:56
1
$\begingroup$

All those prints are terrible compared to what my Printrbot LC v2 can do, I think you should do a full calibration of the printer cooling, temperature, extrusion factor.

Anyway, the issue of layer shift corrects itself because ... it happens again. Nothing else.

Printrbot LC v2 had quite an aggressive acceleration already, and you increased the weight of the Y axis (frame, heated bed, rods) significantly. Have you reduced with M201 the Y acceleration? I wouldn't use anything above 1000, in your case. Maybe even less. Then the layer shift will disappear.

Also, isn't that PVC structure wobbling laterally? you could put some kind of stiffener.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Updated the Q with lots of info. I've done full calibrations before, and that's the reason why I don't print that much. I spend more time fiddling with the printer than the things. I have not adjusted the M201 acceleration, but I will check that out. $\endgroup$ – YetAnotherRandomUser Mar 31 at 2:04
  • $\begingroup$ 1000 isn't extreme at all for acceleration. I'd check jerk settings which are more likely the culprit. $\endgroup$ – R.. GitHub STOP HELPING ICE Mar 31 at 3:38
  • 1
    $\begingroup$ But I'm also very skeptical this is a layer shift (missed steps). It looks like it corrected gradually, in a consistent manner, which is extremely unlikely to happen due to a sequence of missed steps. I think it's much more likely there's something non-rigig in the printer frame that gets put under stress and moves at that layer, and gradually goes back as the stress is relieved. $\endgroup$ – R.. GitHub STOP HELPING ICE Mar 31 at 3:41
  • $\begingroup$ And if it really is layer shifting (missed steps) a likely cause is the severe over-extrusion which has the nozzle gouging into the previous layer. $\endgroup$ – R.. GitHub STOP HELPING ICE Mar 31 at 3:57
1
$\begingroup$

The photos show that the problem is occurring at around the same height. It seems that at a certain Z height something is deflecting the other axis (not sure if it's X or Y) which resolves itself.

I suspect that the rod on which the Z axis rides is either bent or has a dimple, where the rollers pass over it. Either that or perhaps a roller has a dimple.

| improve this answer | |
$\endgroup$
  • $\begingroup$ why would a dimple on the Z axis affect a moving Y axis bed in the direction that the Y axis moves? that doesn't make any sense. $\endgroup$ – YetAnotherRandomUser Apr 2 at 0:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.