1
$\begingroup$

I've already asked this question somewhere else but unfortunately I had little luck.

So... my Ender 3 Pro extruder just started skipping steps, as in the gears (and the gear pinion) will rotate but the filament won't flow. It all started when I changed PLA filament to a new roll; I thought it might have been the roll faulty so I've tried a spool that had been working fine until 2 hours before it all started. Nope, skipping with that one as well.

Here's what I've tried doing so far:

  • Replaced the stock PTFE tubing with Capricorn tubing.
  • Checked that the tubing is tight and does not have play.
  • Replaced the whole extruder system (except for the extruder motor) with a metal Creality system.
  • Performed various cold pulls.
  • Replaced the nozzle.
  • Upped the extruding temperature from 195 °C to 205 °C.
  • Checked that there's the correct distance between the bed and the nozzle.
  • Yelled at the printer.
  • Asked for advice to my cats.

None of the above worked, and my cats looked funny at me. Print settings as below:

  • Filament diameter in the slicer 1.75mm (yes I've checked).
  • Temperature: 195 °C, upped to 205 °C.
  • Print speed: from 20 mm/s for the first layers to 50 mm/s for the infill.

I've also reverted back to the old PTFE tubing as I noticed that the Capricorn was giving too much resistance to the filament. Nope, still skipping.

I've noticed that the extruder gear grips quite firmly onto the filament, so much so that when it starts slipping it actually eats away the filament until it breaks. It's almost like there's a clog somewhere but the tubing is clear, the hot end is clear (I've cleared it and checked multiple times), and the nozzle is brand new.

What else can I try? Have I missed something? Apart from the changes listed above (carried out after the extruder started skipping), the printer is absolutely stock, firmware and everything.

UPDATE: I've changed the factory hot end bloc with a brand new one, changed PTFE tubing one again, making sure it's as close as possible to the nozzle (unscrew nozzle 1/2 turn, fit PTFE, screw nozzle in) but it didn't change anything at all.

The extruder still skips steps as it can't push the filament out of the nozzle. Pushing it manually feels nice and smooth until it hits the nozzle, where I can feel too much resistance.

UPDATE 2: I've modifed the following parameters on the EEPROM to limit the filament flow:

M203 Z5.00 E25.00
M201 E1000

I've also crancked the temperature up to 220°C but it made no difference whatsoever. What I've noticed is that, after cleaning hot end and tubing, it starts skipping after 1 hour of printing, every single time without fail.

UPDATE 3: I've checked the input voltage from the PSU and it's 24V; the Vref for the extruder is 0.744V, so everything looks as expected.

UPDATE 4: The extruder idler pulley has a compression washer to hold it in place without impeding idle spinning; it is usually mounted in the order idler pulley, compression washer and bolt. I've noticed that the pulley wasn't spinning freely this way, so I inverted the order to compression washer, idler pulley and bolt. The bolt head is small enough not to stop the pulley from spinning.

I've also increased the pressure the spring arm excise on the idler pulley, so that the toothed pulley grips more firmly on the filament.

This way I've managed to improve things although not solve them. It's been printing for the last 3 and a half hour without skipping but it's not a solution, as the toothed gear is chewing too aggressively on the filament. In just one hour a good deposit of PLA shavings has formed on the extruder, and I had to blow it away, and this never happened before this all started.

$\endgroup$
  • 1
    $\begingroup$ To exclude the hot/cold end I would disable preventing cold extrusion (M302 S0) and disconnect the Bowden at the cold end and extrude, does it still skip? Also, look at the other side, is unspooling creating more friction? $\endgroup$ – 0scar Apr 10 at 22:40
  • $\begingroup$ Can you elaborate on "Replaced the whole extruder system (except for the extruder motor) with a metal Creality system." ? $\endgroup$ – R.. GitHub STOP HELPING ICE Apr 10 at 22:43
  • $\begingroup$ @0scar Sorry I forgot to mention it, I did that yesterday and the filament extrudes without much problems so no skipping there. The spool is nicely spooled, so it's unraveling (is that a word?) nicely and without much resistance. $\endgroup$ – vale.maio2 Apr 11 at 7:10
  • $\begingroup$ @R..GitHubSTOPHELPINGICE The grey parts in this picture are made of aluminum, and I've changed them from the plastic ones installed by factory. They didn't help. Would a direct drive system help in this case? $\endgroup$ – vale.maio2 Apr 11 at 7:12
  • $\begingroup$ Update: I've changed the factory hot end bloc with a brand new one, changed PTFE tubing one again, making sure it's as close as possible to the nozzle (unscrew nozzle 1/2 turn, fit PTFE, screw nozzle in) but it didn't change anything at all. The extruder still skips steps as it can't push the filament out of the nozzle. Pushing it manually feels nice and smooth until it hits the nozzle, where I can feel too much resistance. $\endgroup$ – vale.maio2 Apr 11 at 14:36
1
$\begingroup$

Since you've said you can feel a problem at the nozzle pushing it through manually, and since you say it goes away for a while after cleaning, you probably have somewhere that molten filament is getting into that it's not supposed to, then solidifying and jamming. Check that the cooling fan for the heatsink on the coldend is working, and that the PTFE tube is properly installed all the way through the heat break and butted up against the nozzle with no gaps or irregularities, and that the pressure fitting is holding it firmly and not allowing it to back out. If you can't find anything wrong, it's possible that something is just defective/damaged inside the hotend assembly.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Unfortunately I've checked all of that. The PTFE tubing is all the way in touching the nozzle, and the pneumatic fittings do a good job holding it in place, as the tubiing does not move back and forth even when I try to move it. Since I've just replaced the whole hotend asembly I'm not sure what could be wrong still with it, unless I've been very unlucky and got a second defective hotend. $\endgroup$ – vale.maio2 Apr 12 at 7:12
  • $\begingroup$ When you say you can feel a problem trying to push it through, do you still get it to extrude ok (with manual pressure)? Can you pull it back easily? $\endgroup$ – R.. GitHub STOP HELPING ICE Apr 12 at 14:50
  • $\begingroup$ I can get it to extrude manually, even when the extruder stops, well, extruding. I wouldn't say easily as it takes a considerable amount of force. $\endgroup$ – vale.maio2 Apr 12 at 15:27
0
$\begingroup$

So, after some day of yelling and disassembling, I figured out what was the issue. As many were suggesting, I indeed had an issue with the tubing lifting from the nozzle. it was lifting, so PLA was slowly infiltrating where it wasn't supposed to be to the point it created a blockage, resulting in skipping.

However, no amount of cleaning and reseating the tubing got rid of it. i've also changed, again, nozzle, tubing and pneumatic fittings to higher quality ones to no avail.

I got absolutely fed up and bought a direct drive conversion kit. One of the cheap ones, reusing most of the stock hardware, including stock extruder and gears. The idea, for me, behind it was that the mass of the extruder, and the much shorter length of tubing, meant that the tubing had no space to move around and let the PLA out.

It looks like it's working so far, I'm 6 hours in on a 10 hours print with no skipping at all. I also managed to ease the pressure that the extruder arm excise on the filament, so it's not being chewed anymore and I'm not seeing any PLA shavings so far.

| improve this answer | |
$\endgroup$
  • $\begingroup$ So it was basically what I said... $\endgroup$ – R.. GitHub STOP HELPING ICE Apr 17 at 17:14
  • $\begingroup$ I'm pretty sure CHEP has a good video or two on dealing with this problem if you have it. It's certainly not a reason to change to a direct drive extruder unless that makes sense for you for other reasons. $\endgroup$ – R.. GitHub STOP HELPING ICE Apr 17 at 17:18
  • $\begingroup$ Those would be youtube.com/watch?v=7tCxO17XZtw and youtube.com/watch?v=Fb4XMbZ0iA4. But I think as long as your bowden tube is cut right, not damaged from wear/heat, and properly inserted, you don't need any of this. You just need to make sure it's installed far enough down to butt up tightly with the nozzle. Unscrew the nozzle a bit while inserting it to let the tube go down farther, then tighten the nozzle back against it. $\endgroup$ – R.. GitHub STOP HELPING ICE Apr 17 at 17:24
  • $\begingroup$ @R..GitHubSTOPHELPINGICE Yes it's exactly what you said but, even after following ALL of those steps, multiple times, I still had the same issue, over and over again. As I said, the weight of the whole direct drive system now keeps the short piece of tubing in place. $\endgroup$ – vale.maio2 Apr 17 at 17:35
  • $\begingroup$ This is a very common problem with bowden systems in general, and Ender 3s in particular. Mine underextruded from the day I bought it, until I pulled out the tube and re-cut it flat, broke two couplers trying to squeeze it in enough to prevent gaps and finally got it working. That lasted a few months before oozing again, so I gave up and switched to a direct drive system, too. Probably the same one you have. Zero problems since. $\endgroup$ – GDorn Apr 23 at 21:45
0
$\begingroup$

I my case helps reducing printing speed, from 100% to 80%. Looks like the filament is cooling noozle to fast. In some large prints at the begining (on first layers) I'm reducing speed to 60%. This looks like the background temperature is not the same in the center and at the borders.

| improve this answer | |
$\endgroup$
0
$\begingroup$

Lot's of factors can cause this behaviour. Firstly check there are no knots in the reel - that can lead to the reel locking up. Second check the PLA temperature and if dual wall (a lot of material being put out) check that the print head is not knocking (running over the top of) excess material due to oozing. I found that after swapping out the print head HE and extruder for new, that the root cause was that I had oozing and was not using the nozzle fan. This led to the head bumping over lumps in longitudinal runs (you could hear a thud), which led to the head getting gradually backed up and the reservoir in the head back-filling with hot PLA. This then created back-pressure into the Bowden tube and then up to the extruder, which is trying to push material into an already full reservoir (head + Bowden). And.. that leads to the cog wheel in the extruder fighting against the pent up flow in the HE. The solution was to put the fan on and that stopped the ooze blobs. Because I had elected to print a fairly heavy object, the wall count was causing an excess build up and my extra-prime setting, although good for thin wall printing, together with the 6mm retract, wasn't right for thick-wall printing. So I could have turned down the extra-prime a bit, but the nozzle fan was the best and easiest option. You have to think about the whole material flow process and how the system is wired: flow-wise. It's a fancy glue gun when you think about it. So you have to be mindful of all of the parameters that can affect material flow.

Having replaced the HE was actually a good idea, as I can now easily prime the head just by pushing material through by hand and feeling the flow. If you are having to push really hard, that means there is a blockage: either the head, or in the tubing or reservoir. Every two months you should maintain the printer and make sure that the head is running clear. The Bowden can also start to restrict in the head where the cleat locks onto the tubing. Heat, plus continual flexing leads to the tube starting to kink. If you are getting flakes at the extruder gear mechanism, then you have a Bowden tube or HE issue. Pushing the PLA by hand will tell you that. After a new HE is put in, you can feel the difference. A Creality 3D Pro head assembly is a few quid. I would suggest keeping a spare set of parts for maintenance work on-hand.

Flakes at the extruder could also be a sure sign of water ingress in the PLA. Look for small warts or bubbles in the print. If so, put the reel in an oven at at 60 °C for about 10-15 minutes. Then let cool off. Ideally you need a dry room to store reels, or a proper bucket with a drying agent inside. In the summer as heat and humidity rises, you'll notice that there's more absorption of water. If your printer is in the same room as a washing machine/dryer, you're asking for trouble. Ideally you need a dry cool space. Or just print a huge batch off and get through the reel quickly...

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.