1
$\begingroup$

I recently bought a second hand Turnigy Fabrikator Mini V2, which, as far as I can tell, is a rebrand of the Malyan M100. After my first few prints I noticed that my prints were very stringy and the filament really didn't want to stick to the bed.

I asked a guy who has quite a bit of experience with 3D printing what could be the problem. He took a look at my benchy print and said it was way too light for a benchy and recommended I'd look at my feedrate (I think the setting is called). So, in repetier host, I told the printer to extrude 50 (I am assuming this is mm, this interface is a little wierd), I am also assuming that this number is the amount of fillament going into the printer, not the amount that comes out of the nozzle. So, I measured that, and it did seem that the amount of fillament going into the printer in was definately a lot less than 50 mm.

As far as I understand this is a setting in the EEPROM. So, I connected to it using minicom (generic USB commandline interface) and sent the command M503, and after doing that, I got a bunch of settings in my terminal (formatting was a mess though and I am not sure if it was complete). After sending this command a second time, nothing happened and after a lot of disconnecting and connecting of the USB cable I figured out that this works only sometimes. I can't figure out how to get it to work consistently (G28 to home the printer always just works though).

I also tried connecting to the printer with other applications like for example Pronterface, but I haven't had any success with anything except for Repetier-host on Windows (I usually use Linux).

So then because I'd like to be able to change EEPROM settings and because I'd like to interface with the printer on Linux I decided that it might be a good idea to update the firmware. So, as a first step, I want to know what firware it is currently running. I couldn't find much information on the Malyan website, (I found a firmware download button that returned a 404) and I also couldn't find much on HobbyKing (the website that used to sell this printer). So, then I tried to send it the M115 command, and yet again, I got nothing back from the printer (I don't know if I never get a response or if I'd get something back after a hundred attempts).

So, now my questions are: what do I do from here? Do I just assume my printer uses some version of Marlin? I remember hearing that a lot of manifacturers just grab off the shelf open source firmware. Is there any way I could get a clue about what it is running? I know there is an stm32 on the pcb so that may be a hint. Could I put something like Marlin on it even if it wasn't running that initially? is that even a good idea? I am assuming I'd at least have to tell it the pin mapping.

Here are images of 2 of the benchy's I printed. I stopped one of them half way through. The other one was my first print and the print speed was way too fast. I also did another print with slower settings but I can't find that one right now (that one was kinda stringy). A failed benchy I printed

My first benchy (the print speed was a little too fast)

As a clarification of my question. As far as I know I have an under extrusion problem, and this is a problem that should (as far as I know) be fixed by changing the extrusion rate in firmware. My problem is that I don't know how to change this setting as I don't even know what firmware it is running. On top of this, when I try sending commands like M503 I get really inconsistent responses. I came to the conclusion of putting new firmware on it because I can think of no other way to fix this problem.

The right question here is probably: how do I change the extrusion rate in the firmware of this specific printer. (Any other solutions are welcome too of course. I have thought about just telling the slicer to compensate in the other direction but as far as I've read it is generally not a good solution to just say in your G-code to compensate for the under extrusion)

So, today I did a lot of testing. And I concluded that when I just insert some fillament into the printer and it hasn't reached the nozzle yet, it extrudes the right amount, but when it reaches the nozzle it just extrudes a lot less. So it seems to be a mechanical problem. I can change the extrusion command to actual extrusion ratio by extruding slower or by increasing the heat of the nozzle. But I have to go quite slow G1 F50 E50 to get anywhere near the right amount of extrusion (still a little more than half a cm short in this case). I did some test prints and it definately seems to make a difference to print slower. These cubes were printed with the one on the right being printed at a little less than half the speed as the one on the right.

enter image description here

I guess it has come to troubleshooting the actual physical extruder (or is this stuff normal and am I just supposed to print at slow speeds on this printer).

The printer is using one of those extruders where the fillament is fed into a tube leading to the nozzle.

enter image description here

The round thingey seems to be turning but it doesn't seem to grip the fillament well enough.

$\endgroup$
  • $\begingroup$ Welcome to 3dPrinting.SE! I'd welcome seeing the Benchy, as this could help us help you tremendously. $\endgroup$ – Pᴀᴜʟsᴛᴇʀ2 Apr 13 at 10:31
  • $\begingroup$ There are multiple questions in your question, basically you direct the question to updating the firmware while you actually have a working printer when dialed in properly! This should be fixable without having to flash new firmware. $\endgroup$ – 0scar Apr 13 at 21:48
  • $\begingroup$ Nice update! Does the stepper motor of the extruder have a flat surface on the shaft? The photo does not seem to show that. The extruder gear grub screw needs to grip on the flat spot of the shaft. If it does, make sure the spring exerts enough pressure, possibly increase the spring tension. $\endgroup$ – 0scar Apr 15 at 4:41
1
$\begingroup$

As there are multiple questions, I'm focusing on the actual problem that causes the Benchy print results (getting it to stick or firmware will not be answered).

Note that a Benchy is a nice, well known print, it actually isn't a good example to calibrate the printer; it is preferred to print calibration cubes, preferably the ones with embossed X, Y and Z.

Under extrusion is usually a result of incorrect hardware/firmware setup or a slicer error. It can also be blockage, but then the extruder needs to skip filament once in a while.

The prints show severe under extrusion. Note that 50 (in the slicer, extrusion rate) means 50 %, this should be 100 %. Basically, you tell the printer that it may only use half the amount of filament it needs to print the object. Furthermore, when you command 100 mm to be extruded, the actual displacement of filament also need to be 100 mm. See "How do I calibrate the extruder of my printer?".

If you really commanded an extrusion of 50 mm (e.g. G1 F250 E50, first reset the length with G92 E0), the amount of filament that is extruded should be exactly 50 mm. If the extruded length is incorrect, the steps/mm in your firmware is incorrect. You can look them up (or change them) with G-code M92.

Please measure your filament diameter at several positions and if it is consistently different from 1.75 mm update the value in your slicer with the mean value.


A very common mistake for people using Cura for the first time is that the Cura default filament diameter is 2.85 mm, not 1.75 mm. But, if you commanded the extrusion yourself with a G-code, it should exactly extrude that amount. If that works, but your print still are under extruded, look into your slicer options.

| improve this answer | |
$\endgroup$
  • $\begingroup$ So, the reason why I didn't post a g-code command was because I didn't know the command, it was a button in a gui. Well, anyways, I did some more testing today and it seems that it does extrude the right amount, but that amount decreases by a lot when the fillament reaches the nozzle, so it seems to be a mechanical problem. I'll edit my original question with more details. $\endgroup$ – TT-392 Apr 14 at 22:44
  • $\begingroup$ @TT-392 That makes sense now! Do you hear skipping noise? Does the filament go back? Please observe what happens and put that in the question. I'll change the answer. $\endgroup$ – 0scar Apr 15 at 4:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.