I just got a Dremel 3D20. I unpacked the machine, and raised the bills platform as documented to setup the spool. Then I tried to level the surface and was able to adjust the left and right knobs but not the rear -- the knob came off completely, but the platform was not lowered. It was firmly pushing against the extruder.

I tried to print an object anyway and the rest part of the object was not forming properly as expected.

I cancelled the job. A few hours later, I tried leveling again. This time around the front knobs also started having the same problem.

I went to the jog mode in the settings screen, and lowered the platform, but it returns to where it was if I try leveling again or print another object.

Printing another object this time around is even worse because the platform completely fails to lower.

There's not enough documentation on Dremel's website.

Does anyone know what's going on?


1 Answer 1


Something similar happened to me during the firsts weeks of 3D printing.

I would recommend you to look for real case scenario leveling steps. Leveling is not that simple and sometimes user manuals don't even mention the many issues you may encounter.

Youtube is a great source of other user's experiences:

Just keep trying until you make it. Some people give up.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .