0
$\begingroup$

Before it stopped working, the stepper motor worked very well and didn't show any problem. I experienced this after I fixed a filament problem. The filament got stuck soI retracted to pull the filament out of the heat nozzle. But when I finished this, the extruder didn't work anymore...

I restarted the system but it didn't work. All the motors work fine, even the extruder motor. The A4988 driver has the right voltage at 1.0 - 1.2 V. I have already replaced my RAMPS shield and AtMega board, but it still does not work! I changed the extruder motor to another axis port and it worked good. The voltage input is stable at 11.2 V

I can't figure out why the extruder motor is not working for the extruder port?

$\endgroup$
1
$\begingroup$

I have found an answer. So dumb🤦‍♂️🤦‍♂️. It need to heat up nozzle before use extrude or retract command

| improve this answer | |
$\endgroup$
  • $\begingroup$ This means that you have #define PREVENT_COLD_EXTRUSION and something like #define EXTRUDE_MINTEMP 170 enabled in your configuration file (which is a good thing!). $\endgroup$ – 0scar Apr 23 at 13:49
  • $\begingroup$ Yes, I have this in my configuration file when I update new Marlin firmware but I forgot it $\endgroup$ – DrPortgas Apr 23 at 13:58
  • $\begingroup$ Glad you found the solution yourself and posted this! Happy printing! $\endgroup$ – 0scar Apr 23 at 14:01
  • $\begingroup$ Thanks!!! What an ridiculous issue!!!:)) $\endgroup$ – DrPortgas Apr 23 at 14:04
  • $\begingroup$ To be honest, I've had a similar experience once :-) But somehow, your question did not trigger my memory. Maybe because you don't mention temperatures; people assume that after the problem you tried to print, but instead you tried to extrude through the display or an attached print application over USB. If this had been added, people may have helped you sooner. If you edit the question to include that, you may receive upvotes to your question! :-) $\endgroup$ – 0scar Apr 23 at 14:10
0
$\begingroup$

When you pulled the filament out of the extruder you most likely induced a voltage back into the stepper driver which fried it.

| improve this answer | |
$\endgroup$
  • $\begingroup$ But when i checked the motor, it still worked $\endgroup$ – DrPortgas Apr 22 at 14:12
  • $\begingroup$ Does the stepper driver what was attached to that motor still work? $\endgroup$ – user77232 Apr 22 at 14:23
  • $\begingroup$ Yes it stil work. I had changed it to work as x axis and it worked $\endgroup$ – DrPortgas Apr 22 at 14:28
  • $\begingroup$ You tried the motor on another stepper driver, but it still doesn't work? If not do you have a way of shorting the motor leads together? If so then do it and try turning the motor by hand. It should give much more resistance to turning when the leads are shorted than when they are not. $\endgroup$ – user77232 Apr 22 at 15:24
  • $\begingroup$ I tried to use another stepper driver from x axis on E0 but it not working. So i changed ramps $\endgroup$ – DrPortgas Apr 22 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.