0
$\begingroup$

I'm currently setting up my custom built 3D printer with a BTT SKR mini E3 v1.2, and so far I have all the endstops and x and y motors working. The problem is that when trying to home my z motors, they just vibrate and make a lot of noise, which tells me they're not getting enough current(which makes sense cause there's two of them as opposed to the other axis). The weird part is that when I manually control them on pronterface, that is just clicking up and down on the arrow wheel, they work perfectly fine. It's only when homing that they vibrate and make a lot of noise. I've tried using the M906 command to raise the current on the motors - they started at 560, and I slowly worked my way up to 4000 - and witnessed no difference. I'm not sure what to adjust from here. Thanks for the help in advance!

$\endgroup$
1
$\begingroup$

Jogging the Z axis may be a sequence of very short moves, happening relatively slowly.

Homing may be a longer, faster move. The homing move would depend more heavily on the maximum velocity, maximum acceleration, and jerk parameters. If there are too high the z axis won't operate properly since the motors will attempt to move faster than is supported by the torque, and the rotating magnetic field will lose control of the permanent magnet rotor.

To fix this, find how the motion limit parameters are controlled for your software, and reduce them all by a factor of 50. It should work, although perhaps too slowly.

I would also reduce the current setting. Microstepping motors doesn't work when the magnetic field is driven to saturation.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.