8
$\begingroup$

I have a (HIC) version of the Prusa i3. I have recently installed the E3D v6 hotend and titan extruder. After fixing some other issues, I noticed that there is no filament being extruded. In addition, the gear looked like it was going in the wrong direction. How can I fix this?

$\endgroup$
8
$\begingroup$

You can either flip the connector for the motor around (i.e. plug it in backwards) or (if you are using Marlin firmware) look for the following line in configuration.h: (using the Arduino editor open the Marlin file For your 3D Printer, one of the tabs is labelled "configuration.h" click on that tab to bring it to the front for editing. use the Edit, Find and put E0 in the find box, click find. When you find the line below

#define INVERT_E0_DIR false

change false to true (or vice-versa). Note that if you go for the connector-flipping route, make sure that you only do this when the printer is turned off.

| improve this answer | |
$\endgroup$
  • 2
    $\begingroup$ Flipping the connector can be described more precise, if your connector allows it: You can flip two leads of one(!) coil, flip the whole assembly, exchange the two coil leads (without flipping them). Whatever is easiest for you. $\endgroup$ – kamuro Jun 17 '16 at 7:57
  • 1
    $\begingroup$ Also, make sure everything is POWERED OFF before you start messing with stepper motor wires. $\endgroup$ – creuzerm Jun 17 '16 at 14:16
  • $\begingroup$ I've incorporated your suggestions, thanks. $\endgroup$ – Tom van der Zanden Jun 17 '16 at 17:07
0
$\begingroup$

Reverse the plug for the motor on the board. Or do firmware. Doesn't matter. *** assuming you have ramps and a standard stepper..

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.