2
$\begingroup$

this is my first time posting on this forum, so bear with me:

This is my first attempt at a RepRap project, and my go-to board has been the RepRapDiscount MKS Rumba+, since I wanted to have functionality with the Makerbase TFT28 Touch-Screen Display. The printer that I have been converting is a 3D Systems Cube 3rd generation. I have successfully modified the printer to accommodate my board and electronics, but have had many issues finding a power supply up to the task of driving the steppers and the heaters (my most-recent attempt was using the Makerbase PWC 2.0 auto-off module; see in link provided https://www.ebay.com/itm/Makerbase-MKS-PWC-Power-Monitoring-Auto-Power-Off-Module-Auto-Off-After-Printing/202971843008?hash=item2f421089c0:g:ws8AAOSwfOlenz-R)

I followed all of the connections to the letter, looking at numerous forums to verify everything was correct, connections were very tight, modifying the original supply cord. My printer powered up and everything functioned properly, except there was no way to turn it off after initially turning it on (M80 and M81 had no effect). I read on the above link that I had to change my value on PS_SUPPLY to 2 and add a PS_ON_PIN in Marlin (not sure to which one on a Rumba+), which I was to perform. However, when I tried to upload my revised firmware through USB, for whatever reason my USB port was not responding at all when I plugged it into my computer (it doesn't show up in device manager anymore either, which is strange since I was able to upload an updated firmware sketch less than a week ago), although everything that was previously on my board was still there, and hence I had a functional printer board.

Unfortunately, I convinced myself that in order to make the changes I needed to get my PWC module to work as intended, I needed to get the updated firmware onto the board somehow. So I looked up forums regarding the original Rumba (I couldn't find nearly any regarding Rumba+) on how to program it through using a USBasp programmer, which involved converting a ten-pin ribbon cable to a six-wire ISCP connection on the Rumba+. I paid extra-close attention when wiring these, following a diagram outlining where to connect each of the six wires detailed in the following youTube video [

at 4:25. I then selected "USBasp" as my programmer, and attempted to upload this way. I could see my Rumba+ responding, which gave me hope, but then the upload failed. Unfortunately, as I was to later learn, uploading via ISP also undoes the bootloader pre-configured into the board; and thus, I also managed to brick my board amidst all of this trouble.

I have been searching every forum possible, reading about ten instructables on how to undo a bricked printer board (none for Rumba+, but for other ATmega2560-based boards, so I tried to work off of them). (I have since removed my power supply). I have used both my USBasp and my Arduino Uno as ISP, and tried using the guidance provided by Nick Gammon at http://www.gammon.com.au/bootloader, which seemed to re-download the bootloader according to the sketch, but all of my attempts to re-upload the Marlin firmware have still failed. My most-recent error has been:

avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer

In my experience, this error has been very vague in what it entails, and I'm inclined to believe that my usb-to-serial ATMega16U2 was damaged when I powered on using the Mks PWC (I suspect this because I don't recall any issues prior-to using the MKS pwc), though I read that the Rumba board does occasionally have this issue at random. My question is is that am I on the right track in trying to restore my board through ISP via my Uno and/or UsbAsp, or is my board damaged beyond repair and unuseable? I can live with not having a serial connection to my board via USB(since I have a wifi module for my TFT28 display), I just need to find a way to get Marlin back onto my Rumba+ (I will resolve the power supply issues later). Thank you and let me know if there is any more relevant information that I can provide.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.