1
$\begingroup$

I've recently configured my Bigtreetech mini e3 v1.2, and I have every aspect of the printer running well except for the initialized homing sequence (the problem is sometimes small enough to where I can still get a good print). Originally what I was running into was that because I used two Z stepper motors, any movement that wasn't manual input on Pronterface would cause the motors to vibrate and make noise (not enough current). Now the only time the Z motors make noise/vibrate is right after the homing is complete and they briefly move up when the nozzle begins to heat, as well as right after the heating is done and the nozzle dips down to begin the print. I suspect it's because of a fast increase in Z speed that I don't necessary need. I've tried changing a multitude of settings in Configuration.h but haven't had any luck. Does anybody know the command that dictates the Z motors to very quickly move upward just after homing and before heating?

$\endgroup$
1
$\begingroup$

Just solved my own problem. Instead of looking in Marlin for the command, I found out the reason it was lifting up quickly was because of a custom command embedded in the G-code by the slicer. I got rid of the command and the problem was solved.

$\endgroup$
2
  • $\begingroup$ Maybe you could add some detail on the actual G-code command and the reason it got inserted by the slicer, that may help others facing similar issues! $\endgroup$
    – 0scar
    May 11 '20 at 8:00
  • $\begingroup$ I think I'm having the same issue any detail on the exact G-code would be helpful. $\endgroup$
    – Wez
    Aug 18 '20 at 11:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.