I want to be able to control my FLSUN QQ over Wi-Fi and don't have OctoPrint or a Raspberry Pi to run it on.


2 Answers 2


Assuming you use Ultimaker Cura to slice, there is a MKS plugin that allows connecting to the MKS WiFi module that comes with the QQ. Just follow these steps:

Install the MKS WiFi Plugin

  1. Open Cura
  2. Click "Marketplace" in top right
  3. Select "Plugins"
  4. Scroll down to find the "MKS WiFi Plugin"
  5. Click on the plugin.
  6. Click "Install"
  7. Restart Cura (quit and reopen)

Configure WiFi

  1. Turn on your QQ
  2. Tap Settings
  3. Tap WiFi
  4. Enable WiFi
  5. Note the IP address and network name
  6. Connect your computer to the printers network
  7. Open your browser
  8. type the IP address of your printer into the address bar
  9. hit enter
  10. Scroll down to "WIFI Configuration"
  11. Select STA
  12. Enter your home network SSID into the field labeled "WIFI"
  13. Enter the password into the field labeled "KEY"
  14. Click configure and reboot

Setup your printer in Cura

  1. Open Cura
  2. Open settings > Printer > Manage Printers...
  3. Click "MKS Wifi"
  4. Click "Add"
  5. Enter the new IP address of your printer (can be found by opening WiFi settings on the printer)
  6. Click Ok 7, Click connect.

Now you should be connected to your printer. After slicing you should have the option to "Print over FLSUN..." In the Monitor interface you should have some other options such as sending commands to the printer, and printing any files already on the SD card, as well as uploading gcode files to the SD card.

Happy Printing

  • $\begingroup$ In case you update the printer's firmware to connect to my local wifi network I had to calibrate it again (using the auto-leveling kit). Also, I had to flash the printer twice for the auto-leveling functionality to work properly. $\endgroup$ Jan 7, 2021 at 9:30
  • $\begingroup$ It's already in STA mode, how do I get it to open an access point? $\endgroup$
    – AndreKR
    Nov 7, 2021 at 23:23

As the auto-install from the Marketplace described in this answer wasn't working , I did have to manually install the MKS WiFi plugin on my Mac (M1 MBPro). To do this I just:

  1. Downloaded the GitHub files (from the plugin webpage, linked in the Marketplace)
  2. Right-clicked the Cura icon in the Applications folder, to show package contents
  3. I then went into the macOS folder and followed the plugin link
  4. Copy the downloaded GitHub files
  5. Restart Cura

I then just followed the printer setup advice in Cura from this answer.

No more messing around with SD cards :)


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .