0
$\begingroup$

I noticed a problem with the combing feature. When I print the first layer with combing set to “not in skin” the extruder does not retract on the first layer. That leads to ugly oozing strings in the visible parts of the prints and also to other problems. E.g. if I want to print a model with tiny circles in the first layer (like for screw holes) the circles get easily pulled away because the extruder is not retracting. At first I thought I’m having sticking problems with the first layer, but I improved that a lot and my prints are perfectly fine now, when I turn off combing completely. In that case the extruder is retracting as desired and the circles stay in place. But turning combing off isn’t always a good option. Sometimes large prints take so much longer and may even have little marks in the visible surfaces where the retractions happened. So I don’t want to turn combing off completely just to be sure the first layer is okay. I saw this behavior with a lot of different models now, so I’m sure, Cura doesn’t always handle the first layer as skin. Setting combing to “not in skin” does definitely not help.

Here are two pictures of the first layer of a print. The first one with combing turned off. You can see the light blue travel lines which mean, the extruder is retracted. enter image description here And the second one with combing set to “not in skin” where you can see the dark blue lines. The extruder is not retracted there which produces the described problems. enter image description here


Updated question to answer:

Thanks a lot for explaining that to me. But I’m afraid the problem still persists. The value of “retraction minimum travel” was at 0.8 mm, which should be fine I assume. Now I’ve set it to zero, just to be sure. The extruder does still not retract as you can see in the picture below.

enter image description here

But when I turn combing off completely, the retraction is happening. So I think it is a problem with the definition of “skin” for the combing mode “not in skin”. The bottom layer doesn’t seem to be treated as skin. By the way, I’m running the latest version of Cura of course (4.6.1).

$\endgroup$
1
$\begingroup$

If you set it to Not in Skin it will not comb and as such it will retract. Retraction travel moves are shown as light blue lines

Light blue are retraction moves. Dark blue are non-retracting moves. Both types are non-extruding moves.

In that respect you would expect that if you set Combing to Not in Skin, it will retract and move to the other position:

Cura combing not in skin

If you wouldn't comb at all, you would see the same:

Cura not combing at all

If you would comb all layers, so no retractions, we would expect dark blue lines:

Cura combing all layers, so no retractions

Basically, Cura does exactly what it needs to do as seen in the screenshots, I cannot place/reproduce the screenshots in the question. To explain this (as commented below by @R..) another setting or settings may have caused preventing retraction like the Retraction Minimum Travel (retract_min_travel) in Cura.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ It's possible there's a bad non-default setting for max travel distance without retraction in OP's config. Just looked it up and that setting is called Retraction Minimum Travel (retract_min_travel) in Cura. $\endgroup$ – R.. GitHub STOP HELPING ICE May 29 at 14:28
  • $\begingroup$ @R..GitHubSTOPHELPINGICE That could be a perfect rational explanation! $\endgroup$ – 0scar May 29 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.