0
$\begingroup$

I installed TH3D to my stock mainboard via this guide, but BLTouch does not work properly.

It does not check all 9 points before point it just go middle then check z then start printing. BLTouch normally needs to check all 9 points before printing or with autobedleveling but somehow mine do not work like this.

$\endgroup$
2
  • $\begingroup$ Hi, welcome to 3DPrinting.SE! Did you insert G29 in your start G-code script? $\endgroup$
    – 0scar
    Jun 12, 2020 at 22:31
  • $\begingroup$ Hey, yes after a while I understand it and find a gcode that is suitable for ender 3 and bltouch now it seems working fine. Ty for your respond :) $\endgroup$
    – Burak0015
    Jun 12, 2020 at 23:30

1 Answer 1

1
$\begingroup$

After setting up the BLTouch in firmware, you need to activate the leveling function for every print by inserting the leveling G-code 'G29' in the start G-code script of your slicer. The code should be placed directly after command G28.

Note that you can test the working of the sensor from the printer display: sensor can be deployed, stowed, reset and tested.

An alternative is to use the G29 and M500 command once in a while (for beds that don't change, don't get handled by excessive force and/or are operated at the same temperature) or store the shape of the bed through the display interface and put the command M420 S1 in your start G-code instead.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .