1
$\begingroup$

I have a FLSUN i3 220x220x240 with:

  • an 2004 LCD (RepRap Discount Smart Controller)
  • an MKS-gen-L-v1.0 printer board running Marlin firmware 2.0.5.x
  • 3D touch sensor,
  • a filament runout sensor.

Everything works fine but for the mechanical Y-min switch: it stays triggered.

(M119) YMIN worked under Marlin 1.1.2; everything is connected correctly and is physically working.

I don't know what to do... Does maybe someone have an idea of what I can do?

These are my config files:

enter image description here

$\endgroup$
  • $\begingroup$ Please help us help you! a photo of the printer would help. Does the trigger signal change if you manually trigger it (which would hint that you wired the switch up as Normal Closed not Normal Open. Also, we'd much prefer to have the text of your configurations uploaded on a site where we don't have to download it, for example, pastebin.com - this makes reading the source code much easier. $\endgroup$ – Trish Jun 14 at 10:16
  • $\begingroup$ @Trish if i trigger by hand no response Y (not defect tested) X ,Z and FILLAMENT SENSOR repond normal on closed and open (test m119) $\endgroup$ – edensan Jun 14 at 11:08
  • 1
    $\begingroup$ I changed pins 14 to 15 and 15 to 14 no difference. Also, if I change Y-min pin to X-min then Y-min trigger and X-min won't trigger! but, when I put the plug in theY-max is working! $\endgroup$ – edensan Jun 14 at 15:58
  • 1
    $\begingroup$ sounds like the pinning on the board and the firmware placement for these pins is mixed up. Another possibility might be shoddy soldering that the pins are not properly connected $\endgroup$ – Trish Jun 15 at 9:57
1
$\begingroup$

This MKS-GEN-L board is in essence a plain RAMPS board, and as such it uses the same pinout apart from some specific pins. Do note the include of the RAMPS pinout in the MKS-GEN-L at the end of the file.

From your comment you have changed the pins 14 and 15, in doing so, you need to plug the Y-min endstop in the Y-max socket after uploading the modified firmware. With the unmodified firmware (no pin switch), if the Y-endstop works in the Y-max socket, this means that you have a hardware issue. The pin labeled 14 is connected to the Y-max instead of the Y-min. If you did the pinout switch and left the endstop in the Y-min socket, then you can conclude that the 15 pin is not connected to the Y-min socket. Basically you don't have a 15 pin that is exposed. Could be that there is an issue on the board with the traces or the soldering.

| improve this answer | |
$\endgroup$
  • $\begingroup$ it worked still messing with the mesh gritpoints right now... $\endgroup$ – edensan Jun 15 at 19:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.