1
$\begingroup$

I need to set the HOME_POS manually since it isn't printing in the center of the bed. But whenever I try to upload it to the Melzi 2.0 board I get an out of sync error.

I am using Arduino IDE on Manjaro Linux, I was able to upload Marlin to the board on Windows 10 but I have since removed that OS. I have the correct settings for the board: Sanguino Atmega 1280 or 1280P (16mhz)

Here is what I have tried to get me this far:

  • Running Arduino IDE as root (administrator) which fixed the permission denied error
  • Changing the Board and the processor settings
  • Uploading a fresh Marlin firmware with no changes
  • Uploading a simple program to my Arduino UNO which worked
  • Changing USB Ports (USB 3.0, USB 2.0)
  • Changing the Baud Rate from 115200 to 57600

Here is the (verbose) error message

Arduino: 1.8.12 (Linux), Board: "Sanguino, ATmega1284 or ATmega1284P (16 MHz)"

Sketch uses 107854 bytes (82%) of program storage space. Maximum is 130048 bytes.
Global variables use 4054 bytes (24%) of dynamic memory, leaving 12330 bytes for local variables. Maximum is 16384 bytes.
/root/.arduino15/packages/arduino/tools/avrdude/6.3.0-arduino17/bin/avrdude -C/root/.arduino15/packages/arduino/tools/avrdude/6.3.0-arduino17/etc/avrdude.conf -v -patmega1284p -carduino -P/dev/ttyUSB0 -b115200 -D -Uflash:w:/tmp/arduino_build_963029/Marlin.ino.hex:i 

avrdude: Version 6.3-20190619
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "/root/.arduino15/packages/arduino/tools/avrdude/6.3.0-arduino17/etc/avrdude.conf"
         User configuration file is "/root/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/ttyUSB0
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x73
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x74
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x61
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x72
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x74
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x0a
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x65
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x63
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x68
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x6f

avrdude done.  Thank you.

An error occurred while uploading the sketch
$\endgroup$
  • $\begingroup$ have you tried installing via ISP pins? $\endgroup$ – Trish Jul 14 at 6:14
  • $\begingroup$ So it was already running Marlin (uploaded from Win10)? You could have used M206 to change the offsets instead of uploading a completely new firmware. On topic, this is a very common and generic error message, a troubleshooting answer can be found here. $\endgroup$ – 0scar Jul 14 at 6:29
  • $\begingroup$ Your board might be using the old bootloader which needs a 57600 baud rate for uploading instead of the default 115200. You'd need to modify that in the respective boards.txt $\endgroup$ – towe Jul 14 at 6:47
  • 1
    $\begingroup$ @towe I tried that it did not work ( I added it to the question now to help narrow it down) $\endgroup$ – Bodhi Teraguchi Jul 15 at 3:02
  • $\begingroup$ That's odd. Enable "Show verbose output during: ... upload" in your IDEs settings please. That should give you the avrdude line the IDE uses to try to upload to the board. $\endgroup$ – towe Jul 15 at 6:09
2
$\begingroup$

Okay thanks to @towe for helping me I figured it out. my Baud Rate was set to 115200 but my board is using the old bootloader so it needed to be 57600. I Changed my boards.txt file to that but the verbose console printed: Overriding Baud Rate : 115200 turns out you need to change it in the serial monitor as well (the little magnifying glass in the top corner of the IDE) after that everything worked great thanks for all the help!

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks for coming back and posting the solution. Glad you got it sorted, happy printing! Please accept the answer after 48 hours. Thanks! $\endgroup$ – 0scar Jul 16 at 9:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.