0
$\begingroup$

I get the error "Thermal runaway on E1. Reset printer." today on my Tevo Tarantula when powering on the printer. The display shows the error and the speaker beeps loudly everytime I power on the printer or reset it.

I use the firmware https://github.com/JimBrown/MarlinTarantula, because I can switch E0 heat nozzle to E1 wires, without soldering; PID's for nozzle were configured, and works fine before I replaced the power supply.

Recently my power supply was broken, and today I installed new power supply, clean nozzle, several times start bed leveling, and on fourth time of homing error appeared.

Power supply voltage tested with a multimeter and the voltage of power supply is 12.06V.

Note: several times printer started bed leveling.

$\endgroup$
6
  • $\begingroup$ Do note that Marlin internal naming for extruders starts with 0 (zero), but, error reporting and menu use naming starting 1 (one). Thermal runaway should only be triggered when heating the hotend. Strange that this happens when you turn on the printer or after levelling. $\endgroup$
    – 0scar
    Jul 18, 2020 at 13:25
  • $\begingroup$ Agree, it is strange. I will test ceramic heater tomorrow. I think that short circute is at ceramic heater either at hotend or board connection. I will replace it if so. I will comment result of tests. $\endgroup$ Jul 18, 2020 at 14:51
  • 1
    $\begingroup$ Issue is solved. Root cause was at broken thermistor circute at board and broken thermistor. I disconnect all wires and power, measure board nest thermistors resistance: E0 = ~120 Oms, (E1 and Bed) = ~700 Oms. I changed pins at Marlin for Tevo pins_RAMPS.h as at 3dprinting.stackexchange.com/questions/10208/…, changed thermistor at everything prints fine. $\endgroup$ Jul 19, 2020 at 13:02
  • 1
    $\begingroup$ Glad you found the root cause!. Please post your comment as an answer and accept it after 48 hours! $\endgroup$
    – 0scar
    Jul 19, 2020 at 15:11
  • $\begingroup$ Ok. Thank you.. $\endgroup$ Jul 22, 2020 at 7:29

1 Answer 1

2
$\begingroup$

Issue is solved!

Root cause was a broken thermistor circuit at board and broken thermistor.

I disconnected all wires and power, measured board and thermistors resistance: E0 = ~120 Ω, (E1 and Bed) = ~700 Ω. I swapped pins for TEMP_0_PIN and TEMP_1_PIN within Marlin for Tevo firmware at pins_RAMPS.h as described in answer on question Change hotend thermistor input in Marlin, changed thermistor and everything prints fine.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .