0
$\begingroup$

I had noisy DRV8825 drivers for my extruder E0 and X, Y, Z axes. I upgraded all to LV8729 drivers but they were still noisy, so I bought two TMC2100 drivers for the X and Y axes and two LV8729 for the Z axis and extruder E0. I updated Marlin (reversing endstops logic and choosing driver types) and I removed the jumpers under the driver pins. But my X and Y axis don't move; eventually the printer halts. What could be wrong?

TMC2100 driver

$\endgroup$
  • 1
    $\begingroup$ Enough that this question makes little sense. Did you only upgrade them? As in: The cabling is unchanged? You will need to provide not a photo of the driver, but the code for the relevant settings in marlin for us to even think of answering this. $\endgroup$ – TomTom Aug 2 at 12:40
  • 1
    $\begingroup$ I found the problem. I'm going to answer my own question. $\endgroup$ – 2012User Aug 2 at 12:41
  • $\begingroup$ Looking forward to read what it was. $\endgroup$ – TomTom Aug 2 at 12:48
0
$\begingroup$

Steps/unit also must be modified. In my case these values made the printer run silent and smooth.

#define DEFAULT_AXIS_STEPS_PER_UNIT   { 100, 200, 6160, 884 }

I set Max feed rate and Max acceleration as below:

#define DEFAULT_MAX_FEEDRATE          { 300, 300, 5, 25 }
#define DEFAULT_MAX_ACCELERATION      { 300, 300, 100, 10000 }
| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.