1
$\begingroup$

Had a print stop about 20 % through and read through some old questions (3+ years) so I'm posting again. Apologies if it's in here some where...

Found the layer to restart, deleted everything from layer 0 to layer 77 (in my case)

The set the E value to the value in layer 76, but still no extrusion. Using Ultimaker Cura. I can dump this but really want to know for future issues with larger prints...

EDITED AFTER ANOTHER ATTEMPT: (Same effect) Sorry, I'm at a loss also made change to G92 code subtracting 5

Here is the start sequence:

;FLAVOR:Marlin
;TIME:41644
;Filament used: 21.0489m
;Layer height: 0.2
;MINX:29.678
;MINY:92.227
;MINZ:0.2
;MAXX:198.806
;MAXY:194.503
;MAXZ:65.6
;Generated with Cura_SteamEngine 4.6.1
M140 S50
M105
M190 S50
M104 S200
M105
M109 S200
M82 ;absolute extrusion mode
; Ender 3 Custom Start G-code
G92 E0 ; Reset Extruder
G28 ; Home all axes
G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
G1 X0.1 Y20 Z0.3 F5000.0 ; Move to start position
G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; Draw the first line
G1 X0.4 Y200.0 Z0.3 F5000.0 ; Move to side a little
G1 X0.4 Y20 Z0.3 F1500.0 E30 ; Draw the second line
G92 E0 ; Reset Extruder
G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
G1 X5 Y20 Z0.3 F5000.0 ; Move over to prevent blob squish
G92 E0
G92 E0
G1 F2700 E-5
;LAYER_COUNT:328
G0 Z15.6

G92 E1744.14148
;was G92E1749.14148

;TIME_ELAPSED:19808.769206
;LAYER:77
;TYPE:SUPPORT
G1 F2700 E1754.14148
G1 F1500 X73.481 Y110.942 E1754.14217
G1 X74.078 Y110.968 E1754.16204
G1 X74.527 Y110.792 E1754.17808
G1 X75.311 Y110.007 E1754.21498
$\endgroup$
  • $\begingroup$ You asked it to extrude 1.7 m of filament. $\endgroup$ – R.. GitHub STOP HELPING ICE Aug 11 at 11:22
  • $\begingroup$ What is the purpose of those 19 non-printing moves? $\endgroup$ – Davo Aug 11 at 13:23
  • $\begingroup$ Not sure Davo, I just cut out the layer detail, I can delete that also if it doesn't do anything $\endgroup$ – Frank Walters Aug 11 at 14:28
1
$\begingroup$

The line you added:

G1 E1749.14148

asks the printer to extrude 1.7 meters of filament. The firmware likely has a feature to ignore such excessive requests as bogus. Then, subsequent extrusion amounts are also huge (1.7m+) relative to the current extruder position (0) and also get ignored. What you meant to do was:

G92 E1749.14148

which means "set the logical extruder position for its current physical position to 1749.14148 mm" so that subsequent extruder positioning commands are interpreted relative to that initial position.

| improve this answer | |
$\endgroup$
  • $\begingroup$ added and edited op, same result though, unfortunately. gears still not turning (checked just in case I had a clog) $\endgroup$ – Frank Walters Aug 11 at 12:51
  • $\begingroup$ I just noticed the E-5 retraction just before the start - if not reversed, is going to prevent any extrusion from happening for a while. Could that be all that's happening? I would set the logical position to 5 less (1744) so that the first extrusion move also undoes the retraction. $\endgroup$ – R.. GitHub STOP HELPING ICE Aug 11 at 13:44
  • $\begingroup$ so change G92 E1749.14148 to G92 E1744.14148? Or could I just delete the E-5 line? $\endgroup$ – Frank Walters Aug 11 at 14:29
  • $\begingroup$ If you delete the E-5 you should expect to see oozing all the way from the end of the prime line to the place where printing resumes. That's why I'd prefer doing it the way I suggested. $\endgroup$ – R.. GitHub STOP HELPING ICE Aug 11 at 14:38
  • $\begingroup$ OK I'm sorry I know this is something I'm doing wrong. changed the line and updated the op to current config and still no love. $\endgroup$ – Frank Walters Aug 11 at 14:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.