3
$\begingroup$

Lately I've been having problems with overhangs not adhering when curvature is outward (stringing across instead) that look like what you'd see at insufficient temperature, and that go away with temperature jacked up a bit (PLA at 220 °C, which is a bit extreme) or fan disabled. Is it possible that the hotend thermistor has drifted and is no longer accurate, making the actual temperature lower than nominal? Or do these things fail hard when they fail?

$\endgroup$
4
  • $\begingroup$ This is an interesting question, but, isn't this best asked at EE.SE? You are hinting to electronics degradation. $\endgroup$
    – 0scar
    Aug 17 '20 at 6:01
  • 1
    $\begingroup$ There might be better experts there but I'd really like to hear an answer in the context of 3D printing, especially if anyone has experienced similar. $\endgroup$ Aug 17 '20 at 14:12
  • $\begingroup$ To begin with, is the value at room temperature still reliable? If you can disconnect the thermistor from the fuser, can you test it in boiling water? these two tests allow a check at least. You can also recalibrate the beta. $\endgroup$
    – FarO
    Jun 9 at 9:53
  • $\begingroup$ Buying multiple thermistors and keeping one for future reference unused after an initial 100h burn-in is also an idea. $\endgroup$
    – FarO
    Jun 9 at 9:55
4
$\begingroup$

Yes, thermistors can drift in value as well as outright failing (usually open).

In my experience this is not uncommon in thermistors operated above 100 degrees C. The drift is typically downward in resistance so the controlled temperature will be less than the desired setpoint, which is exactly what you are observing.

$\endgroup$
3
$\begingroup$

Most thermosensors are functionally nothing different but a temperature dependant resistor. As such, our boards usually use $U=RI$ to get to the resistance, and then compare that to a temperature table. In effect, they put in a regulated potential difference, and measure how much current flows. Plugging this into $U/I=R$ gives the Resistance, which then gives the temperature from the table. In fact, since U is assumed fixed in most firmware, the lookup can also be done directly via the current.

In theory, a resistor's resistance follows $R=R_0(1+\alpha \Delta T)$. Now, Alpha is the proportionality factor of our resistor, delta-T the difference to the tested temperature, at which point the resistor gives R0. Note that Alpha might be also temperature dependant, which is why the firmware looks up the table, not calculates it fresh. So far so good, right? Well... one more thing. Under the standard conditions, we can also use $R_0=\rho \frac l A$ to learn about the resistor, the resistance is the specific resistance times length divided by crossection area.

Now, from just the many factors that play into the thing, we have several points where we might gain error over time:

  • The Thermosensor's resistor itself might break down, for example by operating it too hot. In this case, the factor $\rho$ as well as the effective crossection area get altered. Such a resistor will show a resistance under no heating outside of the known good value. To do this, you'd need to operate your thermosensor above its rating, usually that's in the area of 250 to 290 °C. As an example, the standard e3D Thermosensors are good till about 285 °C, but they also have ones good for up to 500 °C, while the welded thermocouples are only safe for -50 to 250 °C due to it's PTFE sleeve. Removing said sleeve allows to use it for a larger temperature area, but that is not listed.
  • The wiring might be damaged. If the wires to the Thermosensor are kinked and effectively thinner, they might add extra resistance. This would be detectable by measuring the leads to the resistor - they should in best case have close to $0\ \Omega$ resistance. As the wiring is the most stressed part usually, and the wire bundles are often packed well enough to not show up too much even if some strands are broken, such should show up only in the very last stages before a total failure.
  • The board might not measure correctly, for two reasons: either it might look at the wrong reference table as you might have swapped to a different type of thermosensor in a repair, or it might use the wrong (too little/too much) potential difference U to obtain it's measurement I and thus look in the wrong row of the table. For this, there is a fix available in the firmware by swapping to the correct temperature table or calibrating your own one for your off-standard voltage. The latter is a highly involved process and needs you to measure against a known temperature repeatedly.

I am not affiliated with e3D; they are merely one of the best-documented stores for replacement parts I know about, which is why I consulted their catalog.

$\endgroup$
2
  • $\begingroup$ We also assume that temperature and resistance have a linear relationship. From experience with strain gauges, that only mostly holds true., and I would expect it to drift less true over time (e.g. mechanical cracking plus thermal expansion starts giving a more variable cross-sectional area). Additionally, the temperature transfer from the heater to the thermistor is likely variable. $\endgroup$
    – fectin
    Sep 1 '20 at 18:42
  • $\begingroup$ Yep, that's why I wrote Note that Alpha might be also temperature dependant, $\endgroup$
    – Trish
    Sep 1 '20 at 20:31
2
$\begingroup$

I don't think it is the thermistor degrading. To answer your question directly, all my thermistors have failed because the tiny wire has broken off, and generally the fail is “hard” not soft.

It is more likely you’re experiencing absorbed humidity in the filament from it being out on the spool too long. this makes you have to increase the temperature.

I’m sure if you dehydrated the spool in the oven for a bit you’d get better prints and a slightly lower print temp.

Additionally, keep in mind that a lot of PLA on the market nowadays runs at higher temps because it’s laced with something (“PLA+”?). Check the item description for indicators of a new or improved formula.

You could try ordering a thermistor of the same make and testing the temperature of it. You can get a half dozen for about \$10. The Marlin firmware your printer probably uses should have a section for thermistors and what kind you’re using. It’s probably type “1” which is the cheap kind.

You can try using one of those distant head thermometers to measure the temperature wirelessly at the hot end. These are probably over \$100 right now because of COVID. I think that is how a well-resourced person would handle this (i'm not one personally).

Maybe start with the oven and while it’s cooking, research the thermistors and what goes in to replacing one. It’s a good learning experience because one day your hotend may be irreparably clogged and you’ll want to know some of the steps to disassemble it.

$\endgroup$
3
  • 1
    $\begingroup$ What type of thermometer do you mean? The IR (+ laser targeting) ones? Are they accurate on reflective metal surfaces? $\endgroup$ Aug 18 '20 at 6:10
  • 1
    $\begingroup$ Moisture in the filament is a good thought. I'll check that out as a possible cause. I don't have any sort of "PLA+", very intentionally - I want the rigidity of PLA. (See CNC Kitchen's latest video on the topic, which is very nice.) $\endgroup$ Aug 18 '20 at 6:10
  • $\begingroup$ I don't know about the distant thermometers personally. I should've added that I am not a well-resourced person. There have been a few times that I wish I had one though, so it could've been a worthy buy for me before COVID. $\endgroup$
    – K Mmmm
    Aug 21 '20 at 18:16
1
$\begingroup$

It is indeed possible that the thermistor is broken (yet not sure). I am aware of two types of issues with thermistors:

  1. The contact (soldering) is broken, usually due to the temperature extreme variations. The thermistor will indicate the maximum temperature in case of PTC or minimum temperature in case of NTC. In some cases, due to vibrations or other factor, the contact will eventually touch, showing improbable jumps of temperature.

  2. The thermistor is broken internally. In that case it will just indicate a wrong temperature. I can't say if constant temperature or constant delta.

For how to troubleshot the component, however, EE.SE seems more convenient.

$\endgroup$
3
  • $\begingroup$ Printer heats up fine and PID loop is stable. I'm just not sure if it's at the same final temp (relative to requested temp) that it used to be. $\endgroup$ Aug 17 '20 at 14:11
  • $\begingroup$ I suppose you don't have a thermometer to troubleshot this temperature right? $\endgroup$ Aug 17 '20 at 18:55
  • $\begingroup$ I was thinking about getting one but I don't know what type is suitable for measuring temperature of the hotend/nozzle. $\endgroup$ Aug 17 '20 at 21:24
1
$\begingroup$

Adding my 2 cents...

In practice thermistors hard fail. They do not "drift" fast enough for an application to notice. What's most likely happening (assuming that the problem is the temp) is that the reference voltage that is being used to determine the resistance of the thermistor could be faulty. As a simple test, you should get a basic thermometer to measure the temperature of the room. Then check it against the printer when it is sitting idle. If the 2 temps differ by more than 1 degree, then something is wrong. Check if the bed and nozzle thermistors are reading the same value (again to within 1 degree). If they are not, then swap the leads and see if if you get the same problem (with the printer idle of course).

If you have access to a multimeter, then measure the resistance of the thermistor, and then look up what the resistance should be at a certain temp (there are tables for this on the internet).

$\endgroup$
2
  • 1
    $\begingroup$ note that if you use an anaogous thermosensor to compare against, you might just notice a miscalibration of the thermosensors - alcohol and mercury thermometers are almost ridiculously accurate compared to most digital ones. $\endgroup$
    – Trish
    Aug 19 '20 at 9:11
  • $\begingroup$ @Trish, true. I should get a mercury thermometer as well. $\endgroup$
    – user77232
    Aug 19 '20 at 15:51
1
$\begingroup$

NTC Thermistors can fail progressively due to moisture, cracking, changes in the material structure. Don't forget that you are operating them at neat the maximum temperature, not at room temperature.

In this article about NTC resistors for current limiting (subjected to current pulses, but tested also for high temperature stress) they say:

Process of degradation of NTC thermistors has complex character and is, in considerable degree, determined by the total number of applied current impulses or thermal cycles. Initial rise of resistance is caused probably by oxidation process or modification of ionic distribution.

Luckily, after an initial burn-in, they are stable for quite some time. You may just need to recalibrate. Or use a PT1000 resistor which should not have similar issues, and which works without any additional electronics.

See also here for a statement by a manufacturer that NTC ages:

At room temperature the polycrystalline material shows solid-state reactions which lead to an irreversible change in the characteristics (usually resistance increase, change of B value etc). Physical reasons for this may be thermal stress causing a change in concentration of lattice imperfections, oxygen exchange with the environment (with unprotected, non-glass-encapsulated thermistors) or diffusion in the contact areas of metallized surface contacts. At low temperatures these reactions slow down, but at high temperatures they accelerate and finally decline with time. To enhance long-term stability, our NTC thermistors can be subjected to an aging process directly after manufacture.

See this graph from this page for drift as function of time and temperature:

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.