1
$\begingroup$

MY new BLTouch doesn't seem to be actually sensing anything, and I'm not sure how to test it.

Quick background: I have a bit under a decade of experience with printing generally, but essentially none with firmware or any of the specific hardware. I recently got a new Ender 3 Pro, and successfully printed with it for a month.

I recently decided to upgrade my Ender 3 pro motherboard and add a BLTouch. I installed an SKR Mini E3 v2.0, tested briefly (long enough to satisfy myself that it worked as expected, but nothing extensive). I bolted on a BLTouch (not sure if 3.0 or 3.1), built and installed a cable to the dedicated "Z-Probe" port (same pinout as the BLTouch: brown, red, yellow, black, white), and updated the firmware with the binary firmware file from the controller board manufacturer. I have no other mods to electronics.

Right now, I have the following behavior:

  • During startup: BLTouch extends and retracts several times
  • In the LCD menu for BLTouch; select CMD:Self Test: BLTouch turns red, extends and retracts several times.
  • In the LCD menu for BLTouch; select CMD:Extend: BLTouch extends.
  • In the LCD menu for BLTouch; select CMD:Retract: BLTouch retracts.
  • In the LCD menu, select Auto Home: behaves as expected (moves the axes until they hit endstops).

So far so good, but then this:

  • In the LCD menu, select Bed Level: performs Auto Home procedure (as above), moves the BLTouch over the corner of the bed, extends the probe, lowers the Z axis until it hits the endstop. BLTouch probe moves back in. On the way down it turns solid red, then flashing red, then eventually retracts, then the carriage hits the endstop. Process ends.

So, What next? I'd like to check that the BLTouch is actually sending a signal to the board, but I'm not sure how. I've reviewed a bunch of online tutorials and the documentation for the mainboard and the BLTouch, without finding an answer.

Available tools: I have a multimeter and a very cheap oscilloscope. I haven't gotten the maple console installed, but do have a (probably?) functional alternative through the Pango slicer.

$\endgroup$
1
$\begingroup$

Problem is solved, though I still don't know how to test the BLTouch.

I had reversed the power connection (black and white wires) at the connection to the extension cable. Swapping that connector back around restored expected behavior.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Great to see you answered your own question! Please don't forget to accept it after 48 hours. Thanks! $\endgroup$ – 0scar Sep 4 at 8:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.