1
$\begingroup$

I have recently set up my Ender 3 with an SKR MINI E3 V1.2 and a BLTouch which I have been using for a while. After many troubles with compiling the firmware, I managed to compile and upload the firmware; enabling BLTouch and changing the settings.

I've seen it somewhere (I can't remember where) and I think it's correct, but if you go: Motion -> Bed Levelling -> Level Bed, it should run an auto bed leveling sequence. The same should happen if you use G29. If I use the control knob and LCD, my Ender 3 will level the bed manually. It does this by moving to one corner, you manually adjust the height using the knob and then move to another corner and repeat multiple times.

If you look in the Marlin source code:

/**
 * The "Manual Probe" provides a means to do "Auto" Bed Leveling without a probe.
 * Use G29 repeatedly, adjusting the Z height at each point with movement commands
 * or (with LCD_BED_LEVELING) the LCD controller.
 */
//#define PROBE_MANUALLY
//#define MANUAL_PROBE_START_Z 0.2

That is exactly what happens yet as you can see, it is commented out. If I run G29:

>>> G29
SENDING:G29
Mesh Bed Leveling has no data.

It confirms the fact that it wants me to do it manually because it is clearly trying to get previous mesh data rather than level the bed, which means I would have to do it manually.

I cannot find any other settings that would affect this, only what is already commented out, yet it still happens. Could anyone help out here?

$\endgroup$
4
  • $\begingroup$ Can you share the configuration files? Link e.g. to Pastebin.com for people to look for errors. $\endgroup$ – 0scar Sep 16 '20 at 22:01
  • $\begingroup$ I have an SKR PRO that initially didn't allow to store your settings to EEPROM, this is now fixed by storage to flash drive when FLASH_EEPROM_EMULATION is enabled, this is default enabled for your board too, so, is the SD card present? $\endgroup$ – 0scar Sep 17 '20 at 7:44
  • $\begingroup$ @0scar Hopefully mediafire will do! configs. And yes, the SD card is present and works correctly. $\endgroup$ – DreamingInsanity Sep 18 '20 at 17:24
  • $\begingroup$ I feel like such an idiot. I was totally overlooking what type of mesh levelling it was doing. In config.h I hadn't enabled auto_bed_levlling_bilinear and it was just on the manual mesh level setting so it was doing it manually. Lesson learnt! $\endgroup$ – DreamingInsanity Sep 19 '20 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.