2
$\begingroup$

I'm trying to connect my PC to my Anet A8 through Pronterface on Ubuntu.

But when I'm clicking on the "connect" button in Pronterface, all I see is "Connecting ...".

What I did so far

  • added my user to the dialout group
  • tried to run it as root
  • tried different baudrates
  • switch to different USB cables
  • tried to install and run it on a different machine and different OS (Windows) with nearly the same result (additionally I see repeated lines with M105, but no response)

The printer itself works - I want to connect to it, to "PID tune" it, because I added a different fan duct.

How can I make sure the board isn't somewhat damaged, and its just my setup?

$\endgroup$
  • 1
    $\begingroup$ What version of Ubuntu are you using? $\endgroup$ – Mick Sep 22 at 21:43
1
$\begingroup$

I have this printer and used this board many times over USB.

The genuine Arduino boards use the FTDI FT232RL to convert USB signals to UART signals.

The problem with these Arduino based clone boards is that they do not use the FTDI chips as these are too expensive. These boards use a CH340G chip which is a Chinese clone which requires a specific driver to be installed before you can communicate with the board:

CH304G chipset on Anet A8 board Image shows a close-up of the CH340G chipset on the Anet A8 controller board.

When you bought the printer, the SD-card contained the driver that you need to install on your OS. I remember that this driver was for the Windows OS. However, you can download the driver for many platforms (Windows, Mac and Linux) directly from the manufacturer.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Please execuse me for my late reply and thank you for taking the time. The drivers from the manufacturer do not compile on Ubuntu 20.04. But I was able to find, compile and load github.com/skyrocknroll/CH341SER_LINUX. I also tried it with github.com/juliagoda/CH341SER. Sadly both drivers did not help with my issue. The printer is not recognized. Connecting the printer does not show up in syslog or with dmsg. $\endgroup$ – seasick Nov 20 at 20:26
0
$\begingroup$

You may need to install a device driver for the USB interface chip that your printer uses. I'm guessing that the Anet A8 uses a clone of the FTDI FT232RL chip (which was and may still be common with cheap Chinese printers).

If this is the case, you will need to install the appropriate driver from this site: FTDI Chip Virtual COM Port Drivers.

Edit: I can confirm that Pronterface will not work with my Tronxy X1 (which uses an FT232RL clone) on the latest version of Ubuntu.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Please excuse my late reply. Thank you for taking the time trying to help me. I think my Anet A8 does not have the FTDI FT232RL chip, but the CH340G @0scar mentioned in his answer $\endgroup$ – seasick Nov 20 at 20:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.